]> git.pld-linux.org Git - packages/python3-git.git/blob - python3-git.spec
c03c500896967de6cd620302838ce6adfcdba0ff
[packages/python3-git.git] / python3-git.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (require git checkout, not archive?)
4 %bcond_without  doc     # Sphinx documentation
5
6 Summary:        Python Git Library
7 Summary(pl.UTF-8):      Biblioteka Git dla Pythona
8 Name:           python3-git
9 Version:        3.1.26
10 Release:        1
11 License:        BSD
12 Group:          Development/Languages/Python
13 #Source0Download: https://github.com/gitpython-developers/GitPython/releases
14 Source0:        https://github.com/gitpython-developers/GitPython/archive/%{version}/GitPython-%{version}.tar.gz
15 # Source0-md5:  64aa168043fa344ae0dda9e0e969600a
16 Patch0:         markdown.patch
17 URL:            https://pypi.org/project/GitPython/
18 BuildRequires:  python3-modules >= 1:3.4
19 BuildRequires:  python3-setuptools
20 %if %{with tests}
21 BuildRequires:  python3-ddt >= 1.1.1
22 BuildRequires:  python3-gitdb >= 2.0.0
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 %if %{with doc}
27 BuildRequires:  python3-gitdb
28 BuildRequires:  sphinx-pdg
29 %endif
30 Requires:       python3-modules >= 1:3.4
31 Obsoletes:      GitPython
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 GitPython is a Python library used to interact with git repositories,
37 high-level like git-porcelain, or low-level like git-plumbing.
38
39 It provides abstractions of git objects for easy access of repository
40 data, and additionally allows you to access the git repository more
41 directly using either a pure Python implementation, or the faster, but
42 more resource intensive git command implementation.
43
44 %description -l pl.UTF-8
45 GitPython to biblioteka Pythona służąca do pracy z repozytoriami gita,
46 wysokopoziomowo, jak git-porcelain lub niskopoziomowo, jak
47 git-plumbing.
48
49 Biblioteka udostępnia abstrakcje obiektów gita, zapewniając łatwy
50 dostęp do danych repozytorium, a ponadto pozwala na dostęp do
51 repozytorium bardziej bezpośrednio albo przy użyciu czysto pythonowej
52 implementacji, albo szybciej, ale z większym zużyciem zasobów, przy
53 użyciu implementacji poleceń gita.
54
55 %package apidocs
56 Summary:        API documentation for GitPython library
57 Summary(pl.UTF-8):      Dokumentacja API biblioteki GitPython
58 Group:          Documentation
59
60 %description apidocs
61 API documentation for GitPython library.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API biblioteki GitPython.
65
66 %prep
67 %setup -q -n GitPython-%{version}
68 %patch0 -p1
69
70 %build
71 %py3_build %{?with_tests:test}
72
73 %if %{with doc}
74 %{__make} -C doc html
75 %endif
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %py3_install
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc AUTHORS CHANGES LICENSE README.md
88 %dir %{py3_sitescriptdir}/git
89 %{py3_sitescriptdir}/git/*.py
90 %{py3_sitescriptdir}/git/index
91 %{py3_sitescriptdir}/git/objects
92 %{py3_sitescriptdir}/git/py.typed
93 %{py3_sitescriptdir}/git/refs
94 %{py3_sitescriptdir}/git/repo
95 %{py3_sitescriptdir}/git/__pycache__
96 %{py3_sitescriptdir}/GitPython-%{version}-py*.egg-info
97
98 %if %{with doc}
99 %files apidocs
100 %defattr(644,root,root,755)
101 %doc doc/build/html/{_static,*.html,*.js}
102 %endif
This page took 0.095873 seconds and 2 git commands to generate.