]> git.pld-linux.org Git - packages/python3-frozenlist.git/blob - python3-frozenlist.spec
29f63036a4083df1fb99e52897a7f95938af524c
[packages/python3-frozenlist.git] / python3-frozenlist.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # API documentation
4 %bcond_without  tests   # unit tests
5
6 %define         module  frozenlist
7 Summary:        A list-like structure which implements collections.abc.MutableSequence
8 Summary(pl.UTF-8):      Podobna do listy struktura implementująca collections.abc.MutableSequence
9 Name:           python3-%{module}
10 Version:        1.3.0
11 Release:        3
12 License:        Apache v2.0
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/frozenlist/
15 Source0:        https://files.pythonhosted.org/packages/source/f/frozenlist/%{module}-%{version}.tar.gz
16 # Source0-md5:  e65d870bd189ba3c21ab7eb10eab22b7
17 URL:            https://pypi.org/project/frozenlist/
18 BuildRequires:  python3-devel >= 1:3.7
19 BuildRequires:  python3-setuptools >= 1:46.4.0
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 %if %{with doc}
23 BuildRequires:  python3-aiohttp_theme
24 BuildRequires:  sphinx-pdg-3
25 %endif
26 Requires:       python3-modules >= 1:3.7
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 frozenlist.FrozenList is a list-like structure which implements
31 collections.abc.MutableSequence. The list is mutable until
32 FrozenList.freeze is called, after which list modifications
33 raise RuntimeError.
34
35 %description -l pl.UTF-8
36 frozenlist.FrozenList to podobna do listy struktura implementująca
37 collections.abc.MutableSequence. Lista jest modyfikowalna do czasu
38 wywołania FrozenList.freeze, po którym próby modyfikacji rzucą
39 wyjątek RuntimeError.
40
41 %package apidocs
42 Summary:        API documentation for Python %{module} module
43 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona %{module}
44 Group:          Documentation
45
46 %description apidocs
47 API documentation for Python %{module} module.
48
49 %description apidocs -l pl.UTF-8
50 Dokumentacja API modułu Pythona %{module}.
51
52 %prep
53 %setup -q -n %{module}-%{version}
54
55 %build
56 %py3_build
57
58 %if %{with tests}
59 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
60 %{__python3} -m pytest tests
61 %endif
62
63 %if %{with doc}
64 %{__make} -C docs html \
65         SPHINXBUILD=sphinx-build-3
66 %endif
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %py3_install
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc CHANGES.rst CONTRIBUTORS.txt README.rst
79 %dir %{py3_sitedir}/%{module}
80 %{py3_sitedir}/%{module}/*.py
81 %{py3_sitedir}/%{module}/*.pyi
82 %{py3_sitedir}/%{module}/*.pyx
83 %{py3_sitedir}/%{module}/py.typed
84 %attr(755,root,root) %{py3_sitedir}/%{module}/*.so
85 %{py3_sitedir}/%{module}/__pycache__
86 %{py3_sitedir}/%{module}-%{version}-py*.egg-info
87
88 %if %{with doc}
89 %files apidocs
90 %defattr(644,root,root,755)
91 %doc docs/_build/html/{_static,*.html,*.js}
92 %endif
This page took 0.070143 seconds and 2 git commands to generate.