]> git.pld-linux.org Git - packages/python3-fontParts.git/blob - python3-fontParts.spec
5eb7127405a473524ab5494e8e3f6acd4b54dcaa
[packages/python3-fontParts.git] / python3-fontParts.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 Summary:        Set of objects for performing math operations on font data
6 Summary(pl.UTF-8):      Zbiór obiektów do wykonywania operacji matematycznych na danych fontów
7 Name:           python3-fontParts
8 Version:        0.9.11
9 Release:        2
10 License:        MIT
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/fontparts/
13 #Source0:       https://files.pythonhosted.org/packages/source/f/fontparts/fontParts-%{version}.zip
14 Source0:        https://files.pythonhosted.org/packages/1b/73/90add4f89c74b7aff5ed7c90522bfc620cecd1c2fa3cee3bd5b006d44a9c/fontParts-%{version}.zip
15 # Source0-md5:  28dea9f06a9eb45af6e9f06e465fd826
16 URL:            https://pypi.org/project/fontparts/
17 %if %(locale -a | grep -q '^C\.utf8$'; echo $?)
18 BuildRequires:  glibc-localedb-all
19 %endif
20 BuildRequires:  python3-modules >= 1:3.6
21 BuildRequires:  python3-setuptools
22 BuildRequires:  python3-setuptools_scm
23 %if %{with tests}
24 BuildRequires:  python3-booleanOperations >= 0.9.0
25 BuildRequires:  python3-fontMath >= 0.4.8
26 BuildRequires:  python3-fontPens >= 0.1.0
27 # FontTools[ufo,lxml,unicode]>=3.32.0
28 BuildRequires:  python3-fonttools >= 3.32.0
29 BuildRequires:  python3-fs >= 2.2.0
30 BuildRequires:  python3-lxml >= 4.0
31 %endif
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 BuildRequires:  unzip
35 Requires:       python3-modules >= 1:3.6
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 A collection of objects that implement fast font, glyph, etc. math.
41
42 %description -l pl.UTF-8
43 Zbiór obiektów implementujących szybkie operacje matematyczne na
44 fontach, glifach itp.
45
46 %prep
47 %setup -q -n fontParts-%{version}
48
49 %build
50 %py3_build
51
52 %if %{with tests}
53 PYTHONPATH=$(pwd)/Lib \
54 %{__python3} Lib/fontParts/fontshell/test.py
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %py3_install
61
62 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/fontParts/test
63 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/fontParts/fontshell/test.py*
64 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/fontParts/fontshell/__pycache__/test.*.py*
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc LICENSE README.rst
72 %{py3_sitescriptdir}/fontParts
73 %{py3_sitescriptdir}/fontParts-%{version}-py*.egg-info
This page took 0.07208 seconds and 2 git commands to generate.