]> git.pld-linux.org Git - packages/python3-flask-login.git/blob - python3-flask-login.spec
- updated to 0.6.3, finished package, added apidocs
[packages/python3-flask-login.git] / python3-flask-login.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests (one failing)
5
6 %define         module  flask-login
7 Summary:        Flask-Login provides user session management for Flask
8 Summary(pl.UTF-8):      Obsługa zarządzania sesją użytkownika w aplikacjach Flask
9 Name:           python3-%{module}
10 Version:        0.6.3
11 Release:        1
12 License:        MIT
13 Group:          Libraries/Python
14 Source0:        https://files.pythonhosted.org/packages/source/F/Flask-Login/Flask-Login-%{version}.tar.gz
15 # Source0-md5:  689564b8b7f3782f0db382b7aa85bbc2
16 URL:            https://github.com/maxcountryman/flask-login/
17 BuildRequires:  python3-modules >= 1:3.7
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-flask >= 1.0.4
21 BuildRequires:  python3-semantic_version
22 BuildRequires:  python3-werkzeug >= 1.0.1
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 %if %{with doc}
27 BuildRequires:  sphinx-pdg-3
28 %endif
29 Requires:       python3-modules >= 1:3.7
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Flask-Login provides user session management for Flask. It handles the
35 common tasks of logging in, logging out, and remembering your users'
36 sessions over extended periods of time.
37
38 %description -l pl.UTF-8
39 Obsługa zarządzania sesją użytkownika w aplikacjach Flask. Wtyczka
40 obsługuje najpopularniejsze przypadki użycia: logowanie, wylogowanie,
41 zapamiętywanie sesji użytkowników przez określony czas.
42
43 %package apidocs
44 Summary:        API documentation for Python Flask-Login module
45 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona Flask-Login
46 Group:          Documentation
47
48 %description apidocs
49 API documentation for Python Flask-Login module.
50
51 %description apidocs -l pl.UTF-8
52 Dokumentacja API modułu Pythona Flask-Login.
53
54 %prep
55 %setup -q -n Flask-Login-%{version}
56
57 %build
58 %py3_build
59
60 %if %{with tests}
61 PYTHONPATH=$(pwd)/src \
62 %{__python3} -m unittest discover -s tests
63 %endif
64
65 %if %{with doc}
66 PYTHONPATH=$(pwd)/src \
67 %{__make} -C docs html \
68         SOURCEDIR=. \
69         SPHINXBUILD=sphinx-build-3
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %py3_install
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc CHANGES.md LICENSE README.md
83 %{py3_sitescriptdir}/flask_login
84 %{py3_sitescriptdir}/Flask_Login-%{version}-py*.egg-info
85
86 %if %{with doc}
87 %files apidocs
88 %defattr(644,root,root,755)
89 %doc docs/build/html/{_modules,_static,*.html,*.js}
90 %endif
This page took 0.055846 seconds and 3 git commands to generate.