]> git.pld-linux.org Git - packages/python3-feedparser.git/blob - python3-feedparser.spec
- meaningful pl, updated tests invocation (still failing)
[packages/python3-feedparser.git] / python3-feedparser.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (7 tests fail)
4
5 %define         module  feedparser
6 Summary:        Parse RSS and Atom feeds in Python
7 Summary(pl.UTF-8):      Analiza źródeł RSS i Atom dla Pythona
8 Name:           python3-%{module}
9 Version:        6.0.10
10 Release:        1
11 License:        BSD
12 Group:          Libraries/Python
13 Source0:        https://github.com/kurtmckee/feedparser/archive/%{version}.tar.gz
14 # Source0-md5:  d69e59156dfe7b64842befdc1c621a2d
15 URL:            https://github.com/kurtmckee/feedparser
16 BuildRequires:  python3-modules >= 1:3.6
17 BuildRequires:  python3-setuptools
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.710
20 Requires:       python3-modules >= 1:3.6
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Universal Feed Parser is a Python module for downloading and parsing
26 syndicated feeds. It can handle RSS 0.90, Netscape RSS 0.91, Userland
27 RSS 0.91, RSS 0.92, RSS 0.93, RSS 0.94, RSS 1.0, RSS 2.0, Atom 0.3,
28 Atom 1.0, and CDF feeds. It also parses several popular extension
29 modules, including Dublin Core and Apple's iTunes extensions.
30
31 %description -l pl.UTF-8
32 Universal Feed Parser to moduł Pythona do pobierania i analizy
33 syndykowanych źródeł (feedów). Obsługuje RSS 0.90, Netscape RSS 0.91,
34 Userland RSS 0.91, RSS 0.92, RSS 0.93, RSS 0.94, RSS 1.0, RSS 2.0,
35 Atom 0.3, Atom 1.0 oraz CDF. Potrafi obsłużyć także kilka popularnych
36 modułów rozszerzeń, w tym rozszerzenia Dublin Core oraz Apple iTunes.
37
38 %prep
39 %setup -q -n %{module}-%{version}
40
41 %build
42 %py3_build
43
44 %if %{with tests}
45 %{__python3} tests/runtests.py
46 %endif
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %py3_install
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files -n python3-%{module}
57 %defattr(644,root,root,755)
58 %doc LICENSE NEWS README.rst
59 %{py3_sitescriptdir}/feedparser
60 %{py3_sitescriptdir}/feedparser-%{version}-py*.egg-info
This page took 0.065605 seconds and 3 git commands to generate.