]> git.pld-linux.org Git - packages/python3-feedparser.git/blob - python3-feedparser.spec
up to 6.0.8
[packages/python3-feedparser.git] / python3-feedparser.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (3 tests fail)
4
5 %define         module  feedparser
6 Summary:        Parse RSS and Atom feeds in Python
7 Summary(pl.UTF-8):      Biblioteka Feed Parser dla Pythona
8 Name:           python3-%{module}
9 Version:        6.0.8
10 Release:        1
11 License:        BSD
12 Group:          Libraries/Python
13 Source0:        https://github.com/kurtmckee/feedparser/archive/%{version}.tar.gz
14 # Source0-md5:  bd9a217102307b1c4518bff2cab56bb7
15 URL:            https://github.com/kurtmckee/feedparser
16 BuildRequires:  python3-modules >= 1:3.6
17 BuildRequires:  python3-setuptools
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.710
20 Requires:       python3-modules >= 1:3.6
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Universal Feed Parser is a Python module for downloading and parsing
26 syndicated feeds. It can handle RSS 0.90, Netscape RSS 0.91, Userland
27 RSS 0.91, RSS 0.92, RSS 0.93, RSS 0.94, RSS 1.0, RSS 2.0, Atom 0.3,
28 Atom 1.0, and CDF feeds. It also parses several popular extension
29 modules, including Dublin Core and Apple's iTunes extensions.
30
31 %description -l pl.UTF-8
32 Ten pakiet umożliwia analizę źródeł RSS i Atom w Pythonie.
33
34 %prep
35 %setup -q -n %{module}-%{version}
36
37 %build
38 %py3_build
39 %{?with_tests:cd feedparser; PYTHONPATH=../build-3 %{__python3} feedparsertest.py; cd ..}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %py3_install
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files -n python3-%{module}
50 %defattr(644,root,root,755)
51 %doc LICENSE NEWS README.rst
52 %{py3_sitescriptdir}/feedparser
53 %{py3_sitescriptdir}/feedparser-*.egg-info
This page took 0.44685 seconds and 3 git commands to generate.