]> git.pld-linux.org Git - packages/python3-dns.git/blob - python3-dns.spec
- python 3.4
[packages/python3-dns.git] / python3-dns.spec
1
2 %define         module  dns
3
4 Summary:        dnspython3 - a DNS toolkit for Python 3
5 Summary(pl.UTF-8):      dnspython3 - zestaw narzędzi do DNS dla Pythona 3
6 Name:           python3-%{module}
7 Version:        1.11.1
8 Release:        2
9 License:        MIT
10 Group:          Development/Languages/Python
11 Source0:        http://www.dnspython.org/kits3/%{version}/dnspython3-%{version}.tar.gz
12 # Source0-md5:  c0203410e1405c3ee1d70dafa4ad6612
13 URL:            http://www.dnspython.org/
14 BuildRequires:  python3-devel >= 3.0
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.523
17 %pyrequires_eq  python-modules
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 dnspython3 is a DNS toolkit for Python 3. It supports almost all
23 record types. It can be used for queries, zone transfers, and dynamic
24 updates. It supports TSIG authenticated messages and EDNS0.
25
26 dnspython3 provides both high and low level access to DNS. The high
27 level classes perform queries for data of a given name, type, and
28 class, and return an answer set. The low level classes allow direct
29 manipulation of DNS zones, messages, names, and records.
30
31 %description -l pl.UTF-8
32 dnspython3 to zestaw narzędzi do DNS dla Pythona 3. Obsługuje prawie
33 wszystkie rodzaje rekordów. Może być używany do zapytań, transferów
34 stref oraz dynamicznych uaktualnień. Obsługuje uwierzytelnione
35 komunikaty TSIG oraz EDNS0.
36
37 dnspython3 dostarcza zarówno wysoko- jak i niskopoziomowy dostęp do
38 DNS-a. Klasy wysokopoziomowe wykonują zapytania o dane dla podanej
39 nazwy, rodzaju i klasy, a zwracają zbiór odpowiedzi. Klasy
40 niskopoziomowe umożliwiają bezpośrednie manipulacje na strefach,
41 komunikatach, nazwach i rekordach w DNS-ie.
42
43 %prep
44 %setup -q -n dnspython3-%{version}
45
46 %build
47 %{__python3} setup.py build
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %{__python3} setup.py install \
56         --root=$RPM_BUILD_ROOT \
57         --optimize=2
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc ChangeLog LICENSE README
65 %{py3_sitescriptdir}/%{module}
66 %{py3_sitescriptdir}/*.egg-info
67 %{_examplesdir}/%{name}-%{version}
This page took 0.051372 seconds and 3 git commands to generate.