]> git.pld-linux.org Git - packages/python3-certifi.git/blob - python3-certifi.spec
668c63c90b99994db3841d68891024be9912a2fc
[packages/python3-certifi.git] / python3-certifi.spec
1 %define         module  certifi
2
3 # pypi version does not include leading zeros in the date
4 %define         tag 2021.10.08
5 %define         version %(echo %{tag} | sed -e 's/\\.0/./g')
6
7 Summary:        Python 3 package for providing Mozilla's CA Bundle
8 Summary(pl.UTF-8):      Pakiet Pythona 3 udostępniający bazę danych CA z Mozilli
9 Name:           python3-%{module}
10 Version:        %{version}
11 Release:        2
12 License:        MPL v2.0
13 Group:          Libraries/Python
14 #Source0Download: https://github.com/certifi/python-certifi/tags
15 Source0:        https://github.com/certifi/python-certifi/archive/%{tag}/python-certifi-%{tag}.tar.gz
16 # Source0-md5:  23727c99ce0278e5d73d1a41ec3c2ff9
17 URL:            https://certifi.io/
18 BuildRequires:  python3-devel >= 1:3.5
19 BuildRequires:  python3-setuptools
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 Requires:       python3-modules >= 1:3.5
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Certifi is a carefully curated collection of Root Certificates for
28 validating the trustworthiness of SSL certificates while verifying the
29 identity of TLS hosts. It has been extracted from the Requests
30 project.
31
32 %description -l pl.UTF-8
33 Certifi to ostrożnie utrzymywany zbiór głównych certyfikatów
34 potwierdzających zaufanie do certyfikatów SSL podczas weryfikacji
35 tożsamości hostów TLS. Pochodzi z projektu Requests.
36
37 %prep
38 %setup -q -n python-certifi-%{tag}
39
40 %build
41 %py3_build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %py3_install
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc LICENSE README.rst
54 %{py3_sitescriptdir}/%{module}
55 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
This page took 0.05983 seconds and 2 git commands to generate.