]> git.pld-linux.org Git - packages/python3-celery.git/blob - python3-celery.spec
3f9e4da2142e8da4534d1da3090182bc7ba6a5b9
[packages/python3-celery.git] / python3-celery.spec
1
2 # TODO:
3 #       - consider init script / systemd job (uid/gid celery 274 used to be used)
4 #         NOTE: this must not be included and enabled by default in the default
5 #         package! Real-life deployments will mostly be application-specific.
6
7 # Conditional build:
8 %bcond_with     doc             # Sphinx documentation (too much dependencies to be worth the trouble)
9 %bcond_with     tests           # run tests (broken)
10
11 %define         module  celery
12 Summary:        Celery - Distributed Task Query
13 Summary(pl.UTF-8):      Celery - rozproszona kolejka zadań
14 Name:           python3-%{module}
15 Version:        5.0.5
16 Release:        1
17 License:        BSD-like
18 Group:          Development/Languages/Python
19 Source0:        https://files.pythonhosted.org/packages/source/c/celery/%{module}-%{version}.tar.gz
20 # Source0-md5:  a8193028841349fbc7c88e3b67ce608c
21 Patch0:         pytz_dependency.patch
22 URL:            http://celeryproject.org/
23 %if %{with tests}
24 BuildRequires:  python3-billiard >= 3.6.3.0
25 BuildRequires:  python3-billiard < 4
26 BuildRequires:  python3-boto3 >= 1.9.178
27 BuildRequires:  python3-case >= 1.3.1
28 BuildRequires:  python3-click >= 7.0
29 BuildRequires:  python3-click < 8
30 BuildRequires:  python3-click-didyoumean >= 0.0.3
31 BuildRequires:  python3-click-plugins >= 1.1.1
32 BuildRequires:  python3-click-repl >= 0.1.6
33 BuildRequires:  python3-kombu >= 5.0.0
34 BuildRequires:  python3-kombu < 6
35 BuildRequires:  python3-moto >= 1.3.7
36 BuildRequires:  python3-pytest >= 6.0
37 BuildRequires:  python3-pytest-celery
38 BuildRequires:  python3-pytest-subtests
39 BuildRequires:  python3-pytest-timeout >= 1.4.2
40 BuildRequires:  python3-pytz >= 2016.7
41 BuildRequires:  python3-vine >= 5.0.0
42 BuildRequires:  python3-vine < 6
43 %endif
44 BuildRequires:  python3-setuptools
45 BuildRequires:  rpm-pythonprov
46 BuildRequires:  rpmbuild(macros) >= 1.714
47 BuildRequires:  sed >= 4.0
48 %if %{with doc}
49 BuildRequires:  python3-billiard
50 BuildRequires:  python3-kombu >= 5.0.0
51 BuildRequires:  python3-pytz >= 2016.7
52 BuildRequires:  python3-sphinx_celery >= 2.0.0
53 BuildRequires:  python3-sphinx_click >= 2.5.0
54 BuildRequires:  python3-sphinx_testing >= 0.7.2
55 BuildRequires:  sphinx-pdg-3 >= 3.0.0
56 %endif
57 BuildArch:      noarch
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 Celery is an asynchronous task queue/job queue based on distributed
62 message passing. It is focused on real-time operation, but supports
63 scheduling as well.
64
65 %description -l pl.UTF-8
66 Celery to asynchroniczna kolejka zadań oparta na rozproszonym
67 przekazywaniu komunikatów. Skupia się na działaniu w czasie
68 rzeczywistym, ale obsługuje też szeregowanie.
69
70 %package -n celery
71 Summary:        Celery - Distributed Task Query
72 Summary(pl.UTF-8):      Celery - rozproszona kolejka zadań
73 Group:          Development/Languages/Python
74 Requires:       python3-%{module} = %{version}
75
76 %description -n celery
77 Celery is an asynchronous task queue/job queue based on distributed
78 message passing. It is focused on real-time operation, but supports
79 scheduling as well.
80
81 %description -n celery -l pl.UTF-8
82 Celery to asynchroniczna kolejka zadań oparta na rozproszonym
83 przekazywaniu komunikatów. Skupia się na działaniu w czasie
84 rzeczywistym, ale obsługuje też szeregowanie.
85
86 %package apidocs
87 Summary:        API documentation for Celery
88 Summary(pl.UTF-8):      Dokumentacja API Celery
89 Group:          Documentation
90
91 %description apidocs
92 API documentation for Celery.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API Celery.
96
97 %prep
98 %setup -q -n %{module}-%{version}
99
100 %patch0 -p1
101
102 %build
103 %py3_build %{?with_tests:test}
104
105 %if %{with doc}
106 %{__make} -C docs html \
107         SPHINXBUILD=sphinx-build-3
108 %endif
109
110 %install
111 %py3_install
112
113 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
114 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
115 find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
116         | xargs %{__sed} -i '1s|^#!.*python\b|#!%{__python3}|'
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc CONTRIBUTORS.txt Changelog.rst LICENSE README.rst TODO extra/{generic-init.d,supervisord,systemd}
124 %{py3_sitescriptdir}/celery
125 %{py3_sitescriptdir}/celery-%{version}-py*.egg-info
126 %{_examplesdir}/%{name}-%{version}
127
128 %files -n celery
129 %defattr(644,root,root,755)
130 # TODO: extra/{bash-completion,zsh-completion}
131 %attr(755,root,root) %{_bindir}/celery
132
133 %if %{with doc}
134 %files apidocs
135 %defattr(644,root,root,755)
136 %doc docs/_build/html/{_images,_modules,_static,django,getting-started,history,internals,reference,tutorials,userguide,*.html,*.js}
137 %endif
This page took 0.048308 seconds and 2 git commands to generate.