]> git.pld-linux.org Git - packages/python3-breathe.git/blob - python3-breathe.spec
- updated to 4.34.0
[packages/python3-breathe.git] / python3-breathe.spec
1 # NOTE: this package is closely related to Sphinx version, so keep it in sync with sphinx-pdg.spec
2 #
3 # Conditional build:
4 %bcond_without  tests   # unit tests
5
6 Summary:        Sphinx Doxygen renderer
7 Summary(pl.UTF-8):      Renderer Doxygena dla systemu dokumentacji Sphinx
8 Name:           python3-breathe
9 Version:        4.34.0
10 Release:        1
11 License:        BSD
12 Group:          Development/Languages/Python
13 #Source0Download: https://github.com/michaeljones/breathe/releases
14 Source0:        https://github.com/michaeljones/breathe/archive/v%{version}/breathe-%{version}.tar.gz
15 # Source0-md5:  6a4a9af5bcbc778f455da0a00ff3be71
16 URL:            https://github.com/michaeljones/breathe
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-Sphinx >= 4.0
21 BuildRequires:  python3-Sphinx < 6
22 BuildRequires:  python3-docutils >= 0.12
23 BuildRequires:  python3-pytest
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python3-Sphinx >= 3
28 Requires:       python3-modules >= 1:3.6
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Breathe is an extension to reStructuredText and Sphinx to be able to
34 read and render the Doxygen XML output.
35
36 %description -l pl.UTF-8
37 Breathe to rozszerzenie do systemu dokumentacji reStructuredText i
38 Sphinx, pozwalające na odczyt i renderowanie wyjścia XML z Doxygena.
39
40 %prep
41 %setup -q -n breathe-%{version}
42
43 %build
44 %py3_build
45
46 %if %{with tests}
47 cd tests
48 PYTHONPATH=.. \
49 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
50 %{__python3} -m pytest -v
51 cd ..
52 %endif
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %py3_install
58
59 %{__mv} $RPM_BUILD_ROOT%{_bindir}/breathe-apidoc{,-3}
60 ln -sf breathe-apidoc-3 $RPM_BUILD_ROOT%{_bindir}/breathe-apidoc
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc LICENSE README.rst
68 %attr(755,root,root) %{_bindir}/breathe-apidoc
69 %attr(755,root,root) %{_bindir}/breathe-apidoc-3
70 %{py3_sitescriptdir}/breathe
71 %{py3_sitescriptdir}/breathe-%{version}-py*.egg-info
This page took 0.154257 seconds and 3 git commands to generate.