]> git.pld-linux.org Git - packages/python3-breathe.git/blob - python3-breathe.spec
b895ad431da464b4e22aa98c5dee412bfcf29ba0
[packages/python3-breathe.git] / python3-breathe.spec
1 # NOTE: this package is closely related to Sphinx version, so keep it in sync with sphinx-pdg.spec
2 #
3 # Conditional build:
4 %bcond_without  tests   # unit tests
5
6 Summary:        Sphinx Doxygen renderer
7 Summary(pl.UTF-8):      Renderer Doxygena dla systemu dokumentacji Sphinx
8 Name:           python3-breathe
9 Version:        4.33.1
10 Release:        1
11 License:        BSD
12 Group:          Development/Languages/Python
13 #Source0Download: https://github.com/michaeljones/breathe/releases
14 Source0:        https://github.com/michaeljones/breathe/archive/v%{version}/breathe-%{version}.tar.gz
15 # Source0-md5:  0f5cf1b1388473c08172ae1d2b7f778b
16 URL:            https://github.com/michaeljones/breathe
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-Sphinx >= 3.0
21 BuildRequires:  python3-Sphinx < 5
22 BuildRequires:  python3-docutils >= 0.12
23 BuildRequires:  python3-pytest
24 BuildRequires:  python3-six >= 1.9
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 Requires:       python3-Sphinx >= 3
29 Requires:       python3-modules >= 1:3.6
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Breathe is an extension to reStructuredText and Sphinx to be able to
35 read and render the Doxygen XML output.
36
37 %description -l pl.UTF-8
38 Breathe to rozszerzenie do systemu dokumentacji reStructuredText i
39 Sphinx, pozwalające na odczyt i renderowanie wyjścia XML z Doxygena.
40
41 %prep
42 %setup -q -n breathe-%{version}
43
44 %build
45 %py3_build
46
47 %if %{with tests}
48 cd tests
49 PYTHONPATH=.. \
50 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
51 %{__python3} -m pytest -v
52 cd ..
53 %endif
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %py3_install
59
60 %{__mv} $RPM_BUILD_ROOT%{_bindir}/breathe-apidoc{,-3}
61 ln -sf breathe-apidoc-3 $RPM_BUILD_ROOT%{_bindir}/breathe-apidoc
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc LICENSE README.rst
69 %attr(755,root,root) %{_bindir}/breathe-apidoc
70 %attr(755,root,root) %{_bindir}/breathe-apidoc-3
71 %{py3_sitescriptdir}/breathe
72 %{py3_sitescriptdir}/breathe-%{version}-py*.egg-info
This page took 0.074704 seconds and 2 git commands to generate.