]> git.pld-linux.org Git - packages/python3-botocore.git/blob - python3-botocore.spec
0dd8922abb9cb7a92802e0e4c0d4cff982e8c5e7
[packages/python3-botocore.git] / python3-botocore.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests (die with MemoryError)
5
6 Summary:        Low-level, data-driven core of boto 3
7 Summary(pl.UTF-8):      Niskopoziomowy, oparty na danych rdzeń boto 3
8 Name:           python3-botocore
9 Version:        1.24.34
10 Release:        1
11 License:        Apache v2.0
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/botocore/
14 Source0:        https://files.pythonhosted.org/packages/source/b/botocore/botocore-%{version}.tar.gz
15 # Source0-md5:  ef7bf78d394940f1c46599f85a1e06c2
16 URL:            https://pypi.org/project/botocore/
17 BuildRequires:  python3-dateutil >= 2.1
18 BuildRequires:  python3-jmespath >= 0.7.1
19 BuildRequires:  python3-modules >= 1:3.6
20 BuildRequires:  python3-setuptools
21 %if %{with tests}
22 BuildRequires:  python3-behave >= 1.2.5
23 BuildRequires:  python3-dateutil >= 2.1
24 BuildRequires:  python3-jmespath >= 0.7.1
25 BuildRequires:  python3-jsonschema >= 2.5.1
26 BuildRequires:  python3-nose >= 1.3.7
27 BuildRequires:  python3-urllib3 >= 1.25.4
28 %endif
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.714
31 %if %{with doc}
32 BuildRequires:  python3-guzzle_sphinx_theme
33 BuildRequires:  python3-jmespath >= 0.7.1
34 BuildRequires:  sphinx-pdg-3
35 %endif
36 Requires:       python3-modules >= 1:3.6
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 A low-level interface to a growing number of Amazon Web Services. The
42 botocore package is the foundation for the AWS CLI
43 (<https://github.com/aws/aws-cli>) as well as boto3
44 (<https://github.com/boto/boto3>).
45
46 %description -l pl.UTF-8
47 Niskopoziomowy interfejs do rosnącej liczby usług Amazon Web Services.
48 Pakiet botocore jest podstawą dla AWS CLI
49 (<https://github.com/aws/aws-cli>), jak i boto3
50 (<https://github.com/boto/boto3>).
51
52 %package apidocs
53 Summary:        API documentation for Python botocore module
54 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona botocore
55 Group:          Documentation
56
57 %description apidocs
58 API documentation for Python botocore module.
59
60 %description apidocs -l pl.UTF-8
61 Dokumentacja API modułu Pythona botocore.
62
63 %prep
64 %setup -q -n botocore-%{version}
65
66 %build
67 %py3_build
68
69 %if %{with tests}
70 PYTHONPATH=$(pwd) \
71 nosetests-%{py3_ver} tests
72 %endif
73
74 %if %{with doc}
75 PYTHONPATH=$(pwd) \
76 %{__make} -C docs html \
77         SPHINXBUILD=sphinx-build-3
78 %endif
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %py3_install
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc README.rst
91 %{py3_sitescriptdir}/botocore
92 %{py3_sitescriptdir}/botocore-%{version}-py*.egg-info
93
94 %if %{with doc}
95 %files apidocs
96 %defattr(644,root,root,755)
97 %doc docs/build/html/{_static,development,reference,topics,tutorial,*.html,*.js}
98 %endif
This page took 0.154698 seconds and 2 git commands to generate.