]> git.pld-linux.org Git - packages/python3-boto3.git/blob - python3-boto3.spec
- python-boto3.spec updated to 1.24.96 for python 3.7+, compatible with s3transfer...
[packages/python3-boto3.git] / python3-boto3.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (not included in sdist)
4
5 Summary:        AWS SDK for Python 2
6 Summary(pl.UTF-8):      AWS SDK dla Pythona 2
7 Name:           python3-boto3
8 Version:        1.24.96
9 Release:        1
10 License:        Apache v2.0
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/boto3/
13 Source0:        https://files.pythonhosted.org/packages/source/b/boto3/boto3-%{version}.tar.gz
14 # Source0-md5:  116e218c5adffd7d327bf3639f0ccdb6
15 URL:            https://pypi.org/project/boto3/
16 BuildRequires:  python3-modules >= 1:3.7
17 BuildRequires:  python3-setuptools
18 %if %{with tests}
19 BuildRequires:  python3-botocore >= 1.27.96
20 BuildRequires:  python3-botocore < 1.28
21 BuildRequires:  python3-jmespath >= 0.7.1
22 BuildRequires:  python3-jmespath < 1
23 BuildRequires:  python3-nose >= 1.3.3
24 BuildRequires:  python3-s3transfer >= 0.6.0
25 BuildRequires:  python3-s3transfer < 0.7
26 %endif
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.714
29 Requires:       python3-modules >= 1:3.7
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK)
35 for Python, which allows Python developers to write software that
36 makes use of services like Amazon S3 and Amazon EC2.
37
38 %description -l pl.UTF-8
39 Boto3 to pakiet programistyczny (SDK) usług AWS (Amazon Web Services),
40 pozwalający na pisanie w Pythonie oprogramowania wykorzystującego
41 usługi takie jak Amazon S3 i Amazon EC2.
42
43 %prep
44 %setup -q -n boto3-%{version}
45
46 %build
47 %py3_build
48
49 %if %{with tests}
50 nosetests-%{py3_ver} tests
51 %endif
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %py3_install
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README.rst
64 %{py3_sitescriptdir}/boto3
65 %{py3_sitescriptdir}/boto3-%{version}-py*.egg-info
This page took 0.084597 seconds and 3 git commands to generate.