]> git.pld-linux.org Git - packages/python3-asyncio.git/blob - python3-asyncio.spec
- python 3.4
[packages/python3-asyncio.git] / python3-asyncio.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  asyncio
6 Summary:        Asynchronous IO Support
7 Name:           python3-%{module}
8 Version:        0.2.1
9 Release:        2
10 License:        GPL
11 Group:          Development/Languages/Python
12 Source0:        http://pypi.python.org/packages/source/a/asyncio/%{module}-%{version}.tar.gz
13 # Source0-md5:  55dd3fa7aaa243526315d7b6e5ed1ade
14 URL:            https://pypi.python.org/pypi/asyncio
15 BuildRequires:  python3-2to3
16 BuildRequires:  python3-modules >= 3.3
17 BuildRequires:  rpm-pythonprov
18 Requires:       python3 >= 3.3
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Asynchronous IO Support library - includes a pluggable event loop,
24 transport and protocol abstractions similar to those in Twisted, and a
25 higher-level scheduler based on yield from (PEP 380)
26
27 %prep
28 %setup  -q -n asyncio-%{version}
29
30 %build
31 %{__python3} setup.py build
32 %{?with_tests:%{__make} test PYTHON=%{__python3}}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
37 %{__python3} setup.py install \
38         --optimize 2 \
39         --root=$RPM_BUILD_ROOT
40
41 cp -p examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc README
49 %{py3_sitescriptdir}/%{module}
50 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
51 %{_examplesdir}/%{name}-%{version}
This page took 0.117178 seconds and 3 git commands to generate.