]> git.pld-linux.org Git - packages/python3-astroid.git/blob - python3-astroid.spec
- up to 2.5.1
[packages/python3-astroid.git] / python3-astroid.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define module  astroid
6 Summary:        An abstract syntax tree for Python 3 with inference support
7 Summary(pl.UTF-8):      Abstrakcyjnego drzewa składniowe dla Pythona 3 z obsługą wywodu
8 Name:           python3-%{module}
9 Version:        2.5.1
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Development/Languages/Python
13 #Source0Download: https://pypi.org/simple/astroid/
14 Source0:        https://files.pythonhosted.org/packages/source/a/astroid/astroid-%{version}.tar.gz
15 # Source0-md5:  52ad092c3066cdc64870dfa7f9000363
16 Patch0:         %{name}-deps.patch
17 URL:            https://github.com/PyCQA/astroid
18 BuildRequires:  python3-devel >= 1:3.5
19 BuildRequires:  python3-modules >= 1:3.5
20 BuildRequires:  python3-pytest-runner
21 BuildRequires:  python3-setuptools >= 7.0
22 %if %{with tests}
23 BuildRequires:  python3-lazy-object-proxy >= 1.4
24 BuildRequires:  python3-pytest
25 BuildRequires:  python3-six >= 1.12
26 %if "%{py3_ver}" < "3.8"
27 BuildRequires:  python3-typed_ast >= 1.4.0
28 BuildRequires:  python3-typed_ast < 1.5
29 %endif
30 BuildRequires:  python3-wrapt >= 1.11
31 %endif
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 Requires:       python3-modules >= 1:3.5
35 Obsoletes:      python3-logilab-astng
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The aim of this module is to provide a common base representation of
41 Python source code for projects such as pychecker, pyreverse,
42 pylint... Well, actually the development of this library is
43 essentially governed by pylint's needs. It used to be called
44 logilab-astng.
45
46 %description -l pl.UTF-8
47 Celem tego modułu jest dostarczenie wspólnej bazowej reprezentacji
48 kodu źródłowego Pythona dla projektów takich jak pychecker, pyreverse,
49 pylint... Właściwie tworzenie tej biblioteki jest istotnie kierowane
50 potrzebami pylinta. Dawniej nazywała się logilab-astng.
51
52 %prep
53 %setup -q -n %{module}-%{version}
54 %patch0 -p1
55
56 # non-deterministic (skipped if numpy not installed; unittest_brain_numpy_core_multiarray.py fails with numpy 1.16.5
57 %{__rm} tests/unittest_brain_numpy_*
58 # test_knownValues_get_builtin_module_part fails
59 %{__rm} tests/unittest_modutils.py
60
61 %build
62 %py3_build
63
64 %if %{with tests}
65 %{__python3} -m pytest tests
66 %endif
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %py3_install
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc ChangeLog README.rst
79 %{py3_sitescriptdir}/astroid
80 %{py3_sitescriptdir}/astroid-%{version}-py*.egg-info
This page took 0.081373 seconds and 3 git commands to generate.