]> git.pld-linux.org Git - packages/python3-amqp.git/blob - python3-amqp.spec
rebuild with python 3.10
[packages/python3-amqp.git] / python3-amqp.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 %define         module          amqp
7 %define         pypi_name       amqp
8 Summary:        AMQP 0.9.1 client library
9 Summary(pl.UTF-8):      Biblioteka kliencka AMQP 0.9.1
10 Name:           python3-%{module}
11 Version:        5.0.5
12 Release:        3
13 License:        BSD
14 Group:          Libraries/Python
15 Source0:        https://files.pythonhosted.org/packages/source/a/amqp/%{module}-%{version}.tar.gz
16 # Source0-md5:  4b46b380d33d3fb8faccba415a1beaff
17 URL:            https://amqp.readthedocs.io/
18 BuildRequires:  python3-modules >= 1:3.6
19 BuildRequires:  python3-setuptools >= 1:20.6.7
20 %if %{with tests}
21 BuildRequires:  python3-case >= 1.3.1
22 BuildRequires:  python3-pytest >= 3.0
23 BuildRequires:  python3-pytest-rerunfailures >= 6.0
24 BuildRequires:  python3-vine >= 5.0.0
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 %if %{with doc}
29 BuildRequires:  python3-sphinx_celery >= 1.4.8
30 BuildRequires:  sphinx-pdg-3
31 %endif
32 Requires:       python3-modules >= 1:3.6
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This is a fork of amqplib which was originally written by Barry
38 Pederson. It is maintained by the Celery project, and used by kombu as
39 a pure python alternative when librabbitmq is not available.
40
41 This library should be API compatible with librabbitmq.
42
43 %description -l pl.UTF-8
44 Ten projekt to odgałęzienie amqplib, pierwotnie napisane przez
45 Barry'ego Pedersona. Jest utrzymywane przez projekt Celery i używane
46 przez kombu jako czysto pythonowa alternatywa dla librabbitmq, jeśli
47 ta nie jest dostępna.
48
49 Biblioteka powinna być zgodna co do API z librabbitmq.
50
51 %package apidocs
52 Summary:        API documentation for amqp module
53 Summary(pl.UTF-8):      Dokumentacja API modułu amqp
54 Group:          Documentation
55
56 %description apidocs
57 API documentation for amqp module.
58
59 %description apidocs -l pl.UTF-8
60 Dokumentacja API modułu amqp.
61
62 %prep
63 %setup -q -n %{module}-%{version}
64
65 %build
66 %py3_build
67
68 %if %{with tests}
69 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
70 PYTEST_PLUGINS="case.pytest" \
71 %{__python3} -m pytest t/unit
72 %endif
73
74 %if %{with doc}
75 %{__make} -C docs html \
76         SPHINXBUILD=sphinx-build-3
77 %endif
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %py3_install
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc Changelog LICENSE README.rst
90 %{py3_sitescriptdir}/%{module}
91 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
92
93 %if %{with doc}
94 %files apidocs
95 %defattr(644,root,root,755)
96 %doc docs/_build/html/{_modules,_static,reference,*.html,*.js}
97 %endif
This page took 0.075675 seconds and 3 git commands to generate.