]> git.pld-linux.org Git - packages/python3-aiosignal.git/blob - python3-aiosignal.spec
d718a833924c869c6fcd6d41de4c2196bf6ac48f
[packages/python3-aiosignal.git] / python3-aiosignal.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # API documentation
4 %bcond_without  tests   # unit tests
5
6 %define         module  aiosignal
7 Summary:        A list of registered asynchronous callbacks
8 Summary(pl.UTF-8):      Lista zarejestrowanych asynchronicznych wywołań zwrotnych
9 Name:           python3-%{module}
10 Version:        1.2.0
11 Release:        1
12 License:        Apache v2.0
13 Group:          Libraries/Python
14 Source0:        https://files.pythonhosted.org/packages/source/a/aiosignal/%{module}-%{version}.tar.gz
15 # Source0-md5:  011700c3acc576a3a38deade6a4860cb
16 URL:            https://pypi.org/project/aiosignal/
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-frozenlist >= 1.1.0
21 %endif
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.714
24 %if %{with doc}
25 BuildRequires:  python3-aiohttp_theme
26 BuildRequires:  python3-sphinxcontrib-asyncio
27 BuildRequires:  sphinx-pdg-3
28 %endif
29 Requires:       python3-modules >= 1:3.6
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 A project to manage callbacks in asyncio projects.
35
36 Signal is a list of registered asynchronous callbacks.
37
38 %description -l pl.UTF-8
39 Projekt do zarządzania wywołaniami zwrotnymi w projektach asyncio.
40
41 Sygnał to lista zarejestrowanych asynchronicznych wywołań zwrotnych.
42
43 %package apidocs
44 Summary:        API documentation for Python %{module} module
45 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona %{module}
46 Group:          Documentation
47
48 %description apidocs
49 API documentation for Python %{module} module.
50
51 %description apidocs -l pl.UTF-8
52 Dokumentacja API modułu Pythona %{module}.
53
54 %prep
55 %setup -q -n %{module}-%{version}
56
57 %build
58 %py3_build
59
60 %if %{with tests}
61 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
62 %{__python3} -m pytest tests
63 %endif
64
65 %if %{with doc}
66 %{__make} -C docs html \
67         SPHINXBUILD=sphinx-build-3
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %py3_install
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc CHANGES.rst CONTRIBUTORS.txt README.rst
81 %dir %{py3_sitescriptdir}/%{module}
82 %{py3_sitescriptdir}/%{module}/*.py
83 %{py3_sitescriptdir}/%{module}/*.pyi
84 %{py3_sitescriptdir}/%{module}/py.typed
85 %{py3_sitescriptdir}/%{module}/__pycache__
86 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
87
88 %if %{with doc}
89 %files apidocs
90 %defattr(644,root,root,755)
91 %doc docs/_build/html/{_static,*.html,*.js}
92 %endif
This page took 0.071411 seconds and 2 git commands to generate.