]> git.pld-linux.org Git - packages/python3-aiosignal.git/blob - python3-aiosignal.spec
a62bea45358e6fc505c3f930ef82f0733e78ef92
[packages/python3-aiosignal.git] / python3-aiosignal.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # API documentation
4 %bcond_without  tests   # unit tests
5
6 %define         module  aiosignal
7 Summary:        A list of registered asynchronous callbacks
8 Name:           python3-%{module}
9 Version:        1.2.0
10 Release:        1
11 License:        Apache v2.0
12 Group:          Libraries/Python
13 Source0:        https://files.pythonhosted.org/packages/source/a/aiosignal/%{module}-%{version}.tar.gz
14 # Source0-md5:  011700c3acc576a3a38deade6a4860cb
15 URL:            https://pypi.org/project/aiosignal/
16 BuildRequires:  python3-modules >= 1:3.2
17 BuildRequires:  python3-setuptools
18 %if %{with tests}
19 BuildRequires:  python3-frozenlist
20 %endif
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.714
23 %if %{with doc}
24 BuildRequires:  sphinx-pdg-3
25 %endif
26 Requires:       python3-modules >= 1:3.2
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 A project to manage callbacks in asyncio projects.
32
33 Signal is a list of registered asynchronous callbacks.
34
35 %package apidocs
36 Summary:        API documentation for Python %{module} module
37 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona %{module}
38 Group:          Documentation
39
40 %description apidocs
41 API documentation for Python %{module} module.
42
43 %description apidocs -l pl.UTF-8
44 Dokumentacja API modułu Pythona %{module}.
45
46 %prep
47 %setup -q -n %{module}-%{version}
48
49 %build
50 %py3_build
51
52 %if %{with tests}
53 %{__python3} -m pytest tests
54 %endif
55
56 %if %{with doc}
57 %{__make} -C docs html \
58         SPHINXBUILD=sphinx-build-3
59 rm -rf docs/_build/html/_sources
60 %endif
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %py3_install
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc CHANGES.rst CONTRIBUTORS.txt README.rst
73 %dir %{py3_sitescriptdir}/%{module}
74 %{py3_sitescriptdir}/%{module}/*.py
75 %{py3_sitescriptdir}/%{module}/*.pyi
76 %{py3_sitescriptdir}/%{module}/py.typed
77 %{py3_sitescriptdir}/%{module}/__pycache__
78 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
79
80 %if %{with doc}
81 %files apidocs
82 %defattr(644,root,root,755)
83 %doc docs/_build/html/*
84 %endif
This page took 0.054726 seconds and 2 git commands to generate.