]> git.pld-linux.org Git - packages/python3-aiohttp_cors.git/blob - python3-aiohttp_cors.spec
761e113e939ba06a4de309a205830a9c54410eeb
[packages/python3-aiohttp_cors.git] / python3-aiohttp_cors.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 Summary:        CORS support for aiohttp
6 Summary(pl.UTF-8):      Obsługa CORS dla aiohttp
7 Name:           python3-aiohttp_cors
8 Version:        0.7.0
9 Release:        2
10 License:        Apache v2.0
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/aiohttp_cors/
13 Source0:        https://files.pythonhosted.org/packages/source/a/aiohttp_cors/aiohttp-cors-%{version}.tar.gz
14 # Source0-md5:  de3940a901b269be82c8bd9f28d53ff0
15 URL:            https://pypi.org/project/aiohttp_cors/
16 BuildRequires:  python3-modules >= 1:3.4.1
17 BuildRequires:  python3-setuptools >= 1:20.8.1
18 %if %{with tests}
19 BuildRequires:  python3-aiohttp >= 1.1
20 BuildRequires:  python3-pytest
21 BuildRequires:  python3-pytest-cov
22 BuildRequires:  python3-selenium
23 %if "%{py3_ver}" < "3.5"
24 BuildRequires:  python3-typing
25 %endif
26 %endif
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.714
29 Requires:       python3-modules >= 1:3.4.1
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 aiohttp_cors library implements CORS (Cross Origin Resource Sharing)
35 support for aiohttp asyncio-powered asynchronous HTTP server.
36
37 %description -l pl.UTF-8
38 Biblioteka aiohttp_cors implementuje obsługę CORS (Cross Origin
39 Resource Sharing - współdzielenie zasobów z innych źródeł) dla
40 asynchronicznego serwera HTTP aiohttp, opartego na asyncio.
41
42 %prep
43 %setup -q -n aiohttp-cors-%{version}
44
45 %build
46 %py3_build
47
48 %if %{with tests}
49 # disabled tests don't match current aiohttp error reporting (3.7.x)
50 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
51 PYTEST_PLUGINS="aiohttp.pytest_plugin,pytest_cov.plugin" \
52 %{__python3} -m pytest tests -k 'not (test_add_options_route or test_static_resource)'
53 %endif
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %py3_install
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc CHANGES.rst README.rst
66 %{py3_sitescriptdir}/aiohttp_cors
67 %{py3_sitescriptdir}/aiohttp_cors-%{version}-py*.egg-info
This page took 0.05546 seconds and 2 git commands to generate.