]> git.pld-linux.org Git - packages/python3-PyMySQL.git/blob - python3-PyMySQL.spec
3e1c63e34757b1338d00eb4dfe249606b2ed82a0
[packages/python3-PyMySQL.git] / python3-PyMySQL.spec
1 %define snap    20120531
2 %define rel     3
3 Summary:        Pure Python 3 MySQL Client
4 Name:           python3-PyMySQL
5 Version:        0.6
6 Release:        0.%{snap}.%{rel}
7 License:        MIT
8 Group:          Libraries/Python
9 #Source0:       https://github.com/downloads/petehunt/PyMySQL/PyMySQL3-%{version}.tar.gz
10 Source0:        https://nodeload.github.com/petehunt/PyMySQL/tarball/master/%{name}-%{version}.tar.gz
11 # Source0-md5:  653fc737f01b827b4b79ab004613f840
12 URL:            http://www.pymysql.org/
13 BuildRequires:  python3-2to3
14 BuildRequires:  python3-distribute
15 BuildRequires:  python3-modules
16 BuildRequires:  rpm-pythonprov
17 %pyrequires_eq  python3-modules
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This package contains a pure-Python 3 MySQL client library.
23
24 The goal of pymysql is to be a drop-in replacement for MySQLdb and
25 work on CPython 2.3+, Jython, IronPython, PyPy and Python 3.
26
27 %prep
28 #%%setup  -q -n PyMySQL3-%{version}
29 %setup -q -n petehunt-PyMySQL-f670d9a
30 sed -i -e 's#2to3#2to3-3.2#g' build-py3k.sh
31
32 %build
33 sh ./build-py3k.sh
34 cd py3k
35 PYTHONPATH=$(pwd)/pymysql %{__python3} setup.py build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 cd py3k
40 python3 -- setup.py install \
41         --root=$RPM_BUILD_ROOT \
42         --optimize=2
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %{py3_sitescriptdir}/PyMySQL3-*.egg-info
50 %{py3_sitescriptdir}/pymysql
This page took 0.035636 seconds and 2 git commands to generate.