]> git.pld-linux.org Git - projects/template-specs.git/blob - python.spec
- .egg-info since python 2.5
[projects/template-specs.git] / python.spec
1 %define         module  fuse
2 Summary:        -
3 Summary(pl.UTF-8):      -
4 Name:           template
5 Version:        _
6 Release:        0.1
7 License:        - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
8 Group:          Development/Languages/Python
9 Source0:        %{name}-%{version}.tar.gz
10 # Source0-md5:  -
11 URL:            -
12 BuildRequires:  python-devel >= 1:2.5
13 BuildRequires:  rpm-pythonprov
14 #%pyrequires_eq  python-libs
15 %pyrequires_eq  python-modules
16 #BuildArch:     noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20
21 %prep
22 %setup -q -n %{module}-python
23
24 %build
25 python setup.py build
26
27 %install
28 rm -rf $RPM_BUILD_ROOT
29 python setup.py install \
30         --optimize=2 \
31         --root=$RPM_BUILD_ROOT
32
33 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
34 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
35 %py_postclean
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(644,root,root,755)
42 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
43 %{py_sitedir}/*.py[co]
44 %attr(755,root,root) %{py_sitedir}/*.so
45 %if "%{py_ver}" > "2.4"
46 %{py_sitedir}/%{module}-*.egg-info
47 %endif
This page took 0.024587 seconds and 4 git commands to generate.