]> git.pld-linux.org Git - packages/python-zope.exceptions.git/blob - python-zope.exceptions.spec
68efa1ad881b37eb999cbae8c5bfed1cf7ed36f1
[packages/python-zope.exceptions.git] / python-zope.exceptions.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define module  zope.exceptions
7 Summary:        Zope Exceptions
8 Name:           python-%{module}
9 Version:        4.0.8
10 Release:        4
11 License:        ZPL 2.1
12 Group:          Libraries/Python
13 Source0:        https://pypi.python.org/packages/8f/b7/eba9eca6841fa47d9a30f71a602be7615bff4f8e11f85c2840b88a77c68a/zope.exceptions-4.0.8.tar.gz
14 # Source0-md5:  c6f9b3905a48ba0487f82d95fba71c0c
15 URL:            http://www.zope.org/
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 %if %{with python2}
19 BuildRequires:  python >= 1:2.6
20 BuildRequires:  python-setuptools
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3
24 BuildRequires:  python3-setuptools
25 %endif
26 %pyrequires_eq  python-modules
27 Obsoletes:      Zope-Exceptions
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This package contains exception exceptions and implementations which are so
32 general purpose that they don’t belong in Zope application-specific packages.
33
34 %package -n python3-%{module}
35 Summary:        Zope Exceptions
36 Group:          Libraries/Python
37 Requires:       python3-modules
38
39 %description -n python3-%{module}
40 This package contains exception exceptions and implementations which are so
41 general purpose that they don’t belong in Zope application-specific packages.
42
43 %prep
44 %setup -q -n zope.exceptions-%{version}
45
46 %build
47 %if %{with python2}
48 %py_build
49 %endif
50
51 %if %{with python3}
52 %py3_build
53 %endif
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %if %{with python2}
59 %py_install \
60         --install-purelib=%{py_sitedir}
61 %py_postclean
62 %endif
63
64 %if %{with python3}
65 %py3_install \
66         --install-purelib=%{py3_sitedir}
67 %endif
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %if %{with python2}
73 %files
74 %defattr(644,root,root,755)
75 %{py_sitedir}/zope/exceptions
76 %{py_sitedir}/zope.exceptions-*.egg-info
77 %{py_sitedir}/zope.exceptions-*-nspkg.pth
78 %endif
79
80 %if %{with python3}
81 %files -n python3-%{module}
82 %defattr(644,root,root,755)
83 %{py3_sitedir}/zope/exceptions
84 %{py3_sitedir}/zope.exceptions-*.egg-info
85 %{py3_sitedir}/zope.exceptions-*-nspkg.pth
86 %endif
This page took 0.022506 seconds and 2 git commands to generate.