]> git.pld-linux.org Git - packages/python-zope.deprecation.git/blob - python-zope.deprecation.spec
c39f38d76a77edbaf4316178358ab24c9f3d39be
[packages/python-zope.deprecation.git] / python-zope.deprecation.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         _enable_debug_packages  0
8
9 %define module  zope.deprecation
10 Summary:        Deprecation library for Python code
11 Summary(pl.UTF-8):      Biblioteka odradzająca dla kodu w Pythonie
12 Name:           python-%{module}
13 Version:        4.0.2
14 Release:        6
15 License:        ZPL 2.1
16 Group:          Libraries/Python
17 Source0:        http://pypi.python.org/packages/source/z/zope.deprecation/zope.deprecation-%{version}.tar.gz
18 # Source0-md5:  5f8cecce85f2783f9e020f1288e908fd
19 URL:            http://docs.zope.org/zope.deprecation/
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.710
22 %if %{with python2}
23 BuildRequires:  python >= 1:2.6
24 BuildRequires:  python-setuptools
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3
28 BuildRequires:  python3-setuptools
29 %endif
30 Requires:       python-zope.testing
31 Obsoletes:      Zope-Deprecation
32 Provides:       Zope-Deprecation
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This package provides a simple function called deprecated(names, reason) to
38 mark deprecated modules, classes, functions, methods and properties.
39
40 %description -l pl.UTF-8
41 Biblioteka odradzająca dla kodu w Pythonie.
42
43 %package -n python3-%{module}
44 Summary:        Deprecation library for Python code
45 Summary(pl.UTF-8):      Biblioteka odradzająca dla kodu w Pythonie
46 Group:          Libraries/Python
47 Requires:       python3-zope.testing
48
49 %description -n python3-%{module}
50 This package provides a simple function called deprecated(names, reason) to
51 mark deprecated modules, classes, functions, methods and properties.
52
53 %description -n python3-%{module} -l pl.UTF-8
54 Biblioteka odradzająca dla kodu w Pythonie.
55
56 %prep
57 %setup -q -n zope.deprecation-%{version}
58
59 %build
60 %if %{with python2}
61 %py_build %{?with_tests:test}
62 %endif
63
64 %if %{with python3}
65 %py3_build %{?with_tests:test}
66 %endif
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %if %{with python2}
72 # py_sitescriptdir needed as there is the rest of zope.* and it contains some platform-specific code
73 %py_install \
74         --install-purelib=%{py_sitescriptdir}
75
76 %py_postclean
77 %endif
78
79 %if %{with python3}
80 # py_sitescriptdir needed as there is the rest of zope.* and it contains some platform-specific code
81 %py3_install \
82         --install-purelib=%{py3_sitescriptdir}
83 %endif
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %if %{with python2}
89 %files
90 %defattr(644,root,root,755)
91 %doc CHANGES.txt
92 %dir %{py_sitescriptdir}/zope/deprecation
93 %{py_sitescriptdir}/zope/deprecation/*.py[co]
94 %{py_sitescriptdir}/zope.deprecation-*.egg-info
95 %{py_sitescriptdir}/zope.deprecation-*-nspkg.pth
96 %endif
97
98 %if %{with python3}
99 %files -n python3-%{module}
100 %defattr(644,root,root,755)
101 %doc CHANGES.txt
102 %{py3_sitescriptdir}/zope/deprecation
103 %{py3_sitescriptdir}/zope.deprecation-*.egg-info
104 %{py3_sitescriptdir}/zope.deprecation-*-nspkg.pth
105 %endif
This page took 0.077092 seconds and 2 git commands to generate.