]> git.pld-linux.org Git - packages/python-zope.component.git/blob - python-zope.component.spec
cd3f0a1f73a71af1047e297ff06150732e88a35c
[packages/python-zope.component.git] / python-zope.component.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         _enable_debug_packages  0
7
8 %define module  zope.component
9 Summary:        Core of the Zope Component Architecture
10 Summary(pl.UTF-8):      Rdzeń Zope Component Architecture
11 Name:           python-%{module}
12 Version:        4.4.1
13 Release:        9
14 License:        ZPL 2.1
15 Group:          Libraries/Python
16 Source0:        https://files.pythonhosted.org/packages/source/z/zope.component/zope.component-%{version}.tar.gz
17 # Source0-md5:  dc43aca08995751159e4b0f98f5afc5a
18 %if %{with python2}
19 BuildRequires:  python >= 1:2.5
20 BuildRequires:  python-devel >= 1:2.5
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3 >= 1:3.2
25 BuildRequires:  python3-devel >= 1:3.2
26 BuildRequires:  python3-setuptools
27 %endif
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.710
30 Requires:       python-zope.deferredimport
31 Requires:       python-zope.deprecation
32 Requires:       python-zope.event
33 Requires:       python-zope.interface
34 Requires:       python-zope.proxy
35 Requires:       python-zope.testing
36 Requires:       python-modules
37 Obsoletes:      Zope-Component
38 Provides:       Zope-Component
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Core of the Zope Component Architecture.
44
45 %description -l pl.UTF-8
46 Rdzeń architektury komponentowej Zope Component Architecture.
47
48 %package -n python3-zope.component
49 Summary:        Core of the Zope Component Architecture
50 Summary(pl.UTF-8):      Rdzeń Zope Component Architecture
51 Group:          Libraries/Python
52
53 %description -n python3-zope.component
54 Core of the Zope Component Architecture.
55
56 %description -n python3-zope.component -l pl.UTF-8
57 Rdzeń architektury komponentowej Zope Component Architecture.
58
59 %prep
60 %setup -q -n zope.component-%{version}
61
62 %build
63 %if %{with python2}
64 %py_build %{?with_tests:test}
65 %endif
66
67 %if %{with python3}
68 %py3_build %{?with_tests:test}
69 %endif
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %if %{with python2}
75 %py_install \
76         --install-purelib=%{py_sitescriptdir}
77
78 %py_postclean
79 %endif
80
81 %if %{with python3}
82 %py3_install \
83         --install-purelib=%{py3_sitescriptdir}
84 %endif
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %if %{with python2}
92 %{py_sitescriptdir}/zope/component
93 %{py_sitescriptdir}/zope.component-*.egg-info
94 %{py_sitescriptdir}/zope.component-*-nspkg.pth
95 %endif
96
97 %files -n python3-zope.component
98 %defattr(644,root,root,755)
99 %if %{with python3}
100 %{py3_sitescriptdir}/zope/component
101 %{py3_sitescriptdir}/zope.component-*.egg-info
102 %{py3_sitescriptdir}/zope.component-*-nspkg.pth
103 %endif
This page took 0.071977 seconds and 2 git commands to generate.