]> git.pld-linux.org Git - packages/python-zope.component.git/blob - python-zope.component.spec
a06aa0610c24fc68f01655bdc70299e12a318fc0
[packages/python-zope.component.git] / python-zope.component.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         _enable_debug_packages  0
7
8 %define module  zope.component
9 Summary:        Core of the Zope Component Architecture
10 Summary(pl.UTF-8):      Rdzeń Zope Component Architecture
11 Name:           python-%{module}
12 Version:        4.4.1
13 Release:        5
14 License:        ZPL 2.1
15 Group:          Libraries/Python
16 Source0:        https://files.pythonhosted.org/packages/source/z/zope.component/zope.component-%{version}.tar.gz
17 # Source0-md5:  dc43aca08995751159e4b0f98f5afc5a
18 %if %{with python2}
19 BuildRequires:  python >= 1:2.5
20 BuildRequires:  python-devel >= 1:2.5
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3 >= 1:3.2
25 BuildRequires:  python3-devel >= 1:3.2
26 BuildRequires:  python3-setuptools
27 %endif
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.710
30 Requires:       python-zope.deferredimport
31 Requires:       python-zope.deprecation
32 Requires:       python-zope.event
33 Requires:       python-zope.interface
34 Requires:       python-zope.proxy
35 Requires:       python-zope.testing
36 Requires:       python-modules
37 Obsoletes:      Zope-Component
38 Provides:       Zope-Component
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Core of the Zope Component Architecture.
43
44 %description -l pl.UTF-8
45 Rdzeń architektury komponentowej Zope Component Architecture.
46
47 %package -n python3-zope.component
48 Summary:        Core of the Zope Component Architecture
49 Summary(pl.UTF-8):      Rdzeń Zope Component Architecture
50 Group:          Libraries/Python
51
52 %description -n python3-zope.component
53 Core of the Zope Component Architecture.
54
55 %description -n python3-zope.component -l pl.UTF-8
56 Rdzeń architektury komponentowej Zope Component Architecture.
57
58 %prep
59 %setup -q -n zope.component-%{version}
60
61 %build
62 %if %{with python2}
63 %py_build %{?with_tests:test}
64 %endif
65
66 %if %{with python3}
67 %py3_build %{?with_tests:test}
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %if %{with python2}
74 %py_install \
75         --install-purelib=%{py_sitedir}
76
77 %py_postclean
78 %endif
79
80 %if %{with python3}
81 %py3_install \
82         --install-purelib=%{py3_sitedir}
83 %endif
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %if %{with python2}
91 %{py_sitedir}/zope/component
92 %{py_sitedir}/zope.component-*.egg-info
93 %{py_sitedir}/zope.component-*-nspkg.pth
94 %endif
95
96 %files -n python3-zope.component
97 %defattr(644,root,root,755)
98 %if %{with python3}
99 %{py3_sitedir}/zope/component
100 %{py3_sitedir}/zope.component-*.egg-info
101 %{py3_sitedir}/zope.component-*-nspkg.pth
102 %endif
This page took 0.178494 seconds and 2 git commands to generate.