]> git.pld-linux.org Git - packages/python-yara.git/blob - python-yara.spec
up to 4.3.1
[packages/python-yara.git] / python-yara.spec
1 %define         module  yara
2 Summary:        Python bindings to yara library
3 Name:           python-%{module}
4 Version:        4.3.1
5 Release:        1
6 License:        Apache v2.0
7 Group:          Development/Languages/Python
8 Source0:        https://github.com/VirusTotal/yara-python/archive/v%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  3232b37fa7b7edb0f76d977767ed5bbf
10 URL:            http://virustotal.github.io/yara/
11 BuildRequires:  python-devel
12 BuildRequires:  python-modules
13 BuildRequires:  python-setuptools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.714
16 BuildRequires:  yara-devel
17 Requires:       python-modules
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This is a Python extension that gives you access to YARA's powerful
22 features from your own Python scripts.
23
24 %prep
25 %setup -q -n %{module}-python-%{version}
26
27 %build
28 %py_build
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 %py_install
33
34 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
35 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
36 %py_postclean
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %doc README.rst
44 %attr(755,root,root) %{py_sitedir}/yara.so
45 %if "%{py_ver}" > "2.4"
46 %{py_sitedir}/yara_python-*.egg-info
47 %endif
This page took 0.053686 seconds and 3 git commands to generate.