]> git.pld-linux.org Git - packages/python-yamlloader.git/blob - python-yamlloader.spec
c87655fc8908e34974d4fbc080d5bfd9b3185475
[packages/python-yamlloader.git] / python-yamlloader.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Ordered YAML loader and dumper for PyYAML
7 Summary(pl.UTF-8):      Moduł dla PyYAML-a do wczytywania i zapisywania YAML-a z zachowaniem porządku
8 Name:           python-yamlloader
9 Version:        0.5.5
10 Release:        2
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/yamlloader/
14 Source0:        https://files.pythonhosted.org/packages/source/y/yamlloader/yamlloader-%{version}.tar.gz
15 # Source0-md5:  2e0750ace81235f750c072833d79c4c3
16 URL:            https://pypi.org/project/yamlloader/
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.7
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-modules >= 1:3.4
23 BuildRequires:  python3-setuptools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python-modules >= 1:2.7
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This module provides loaders and dumpers for PyYAML. Currently, an
33 OrderedDict loader/dumper is implemented, allowing to keep items order
34 when loading resp. dumping a file from/to an OrderedDict (or regular
35 dict in Python 3.7+).
36
37 %description -l pl.UTF-8
38 Ten moduł udostępnia funkcje do wczytywania i zapisywania dla
39 PyYAML-a. Obecnie obsługiwane są struktury OrderedDict, pozwalające na
40 zachowanie kolejności między wczytaniem a zrzucaniem (dla Pythona 3.7+
41 obsługiwane są także zwykłe słowniki).
42
43 %package -n python3-yamlloader
44 Summary:        Ordered YAML loader and dumper for PyYAML
45 Summary(pl.UTF-8):      Moduł dla PyYAML-a do wczytywania i zapisywania YAML-a z zachowaniem porządku
46 Group:          Libraries/Python
47 Requires:       python3-modules >= 1:3.4
48
49 %description -n python3-yamlloader
50 This module provides loaders and dumpers for PyYAML. Currently, an
51 OrderedDict loader/dumper is implemented, allowing to keep items order
52 when loading resp. dumping a file from/to an OrderedDict (or regular
53 dict in Python 3.7+).
54
55 %description -n python3-yamlloader -l pl.UTF-8
56 Ten moduł udostępnia funkcje do wczytywania i zapisywania dla
57 PyYAML-a. Obecnie obsługiwane są struktury OrderedDict, pozwalające na
58 zachowanie kolejności między wczytaniem a zrzucaniem (dla Pythona 3.7+
59 obsługiwane są także zwykłe słowniki).
60
61 %prep
62 %setup -q -n yamlloader-%{version}
63
64 %build
65 %if %{with python2}
66 %py_build
67 %endif
68
69 %if %{with python3}
70 %py3_build
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %if %{with python2}
77 %py_install
78
79 %py_postclean
80 %endif
81
82 %if %{with python3}
83 %py3_install
84 %endif
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %if %{with python2}
90 %files
91 %defattr(644,root,root,755)
92 %doc LICENSE README.rst
93 %{py_sitescriptdir}/yamlloader
94 %{py_sitescriptdir}/yamlloader-%{version}-py*.egg-info
95 %endif
96
97 %if %{with python3}
98 %files -n python3-yamlloader
99 %defattr(644,root,root,755)
100 %doc LICENSE README.rst
101 %{py3_sitescriptdir}/yamlloader
102 %{py3_sitescriptdir}/yamlloader-%{version}-py*.egg-info
103 %endif
This page took 0.070374 seconds and 2 git commands to generate.