]> git.pld-linux.org Git - packages/python-xapp.git/blob - python-xapp.spec
ce95666c348f5a5390b25711b04248cc17488b9b
[packages/python-xapp.git] / python-xapp.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  xapp
7 Summary:        Python bindings for xapps
8 Name:           python-%{module}
9 Version:        1.8.1
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries/Python
13 Source0:        https://github.com/linuxmint/python-xapp/archive/%{version}.tar.gz
14 # Source0-md5:  f6a59d8f7177cfb9b89b3097ed176061
15 URL:            https://github.com/linuxmint/python-xapp/
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 %if %{with python2}
19 BuildRequires:  python-distribute
20 BuildRequires:  python-modules
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-distribute
24 BuildRequires:  python3-modules
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Python bindings for xapps.
30
31 %package -n python3-%{module}
32 Summary:        Python bindings for xapps.
33 Group:          Libraries/Python
34
35 %description -n python3-%{module}
36 Python bindings for xapps.
37
38 %prep
39 %setup -q
40
41 %build
42 %if %{with python2}
43 %py_build
44 %endif
45
46 %if %{with python3}
47 %py3_build
48 %endif
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %if %{with python2}
54 %py_install
55
56 %py_postclean
57
58 %endif
59
60 %if %{with python3}
61 %py3_install
62
63 %endif
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %if %{with python2}
69 %files
70 %defattr(644,root,root,755)
71 %dir %{py_sitescriptdir}/xapp
72 %{py_sitescriptdir}/xapp/*.py[co]
73 %if "%{py_ver}" > "2.4"
74 %{py_sitescriptdir}/python_xapp-%{version}-py*.egg-info
75 %endif
76 %endif
77
78 %if %{with python3}
79 %files -n python3-%{module}
80 %defattr(644,root,root,755)
81 %dir %{py3_sitescriptdir}/xapp
82 %{py3_sitescriptdir}/xapp/*.py
83 %dir %{py3_sitescriptdir}/xapp/__pycache__
84 %{py3_sitescriptdir}/xapp/__pycache__/*.py[co]
85 %{py3_sitescriptdir}/python_xapp-%{version}-py*.egg-info
86 %endif
This page took 0.050254 seconds and 2 git commands to generate.