]> git.pld-linux.org Git - packages/python-vcversioner.git/blob - python-vcversioner.spec
f15686029cbdeada1cda9919e3c6bf70bd0d2bb1
[packages/python-vcversioner.git] / python-vcversioner.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  template
7 Summary:        Use version control tags to discover version numbers
8 Summary(pl.UTF-8):      Użycie znaczników kontroli wersji do wykrywania numerów wersji
9 Name:           python-vcversioner
10 Version:        2.16.0.0
11 Release:        2
12 License:        ISC
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/simple/vcversioner/
15 Source0:        https://pypi.python.org/packages/source/v/vcversioner/vcversioner-%{version}.tar.gz
16 # Source0-md5:  aab6ef5e0cf8614a1b1140ed5b7f107d
17 URL:            https://github.com/habnabit/vcversioner
18 BuildRequires:  rpm-pythonprov
19 # for the py_build, py_install macros
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 %if %{with python2}
22 BuildRequires:  python-modules >= 1:2.6
23 BuildRequires:  python-setuptools
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-modules >= 1:3.3
27 BuildRequires:  python3-setuptools
28 %endif
29 Requires:       python-modules >= 1:2.6
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This module allows you to write a setup.py with no version information
35 specified, and vcversioner will find a recent, properly-formatted VCS
36 tag and extract a version from it.
37
38 %description -l pl.UTF-8
39 Ten moduł pozwala na tworzenie plików setup.py nie zawierających
40 informacji o wersji; vcversioner znajdzie najnowszy, właściwie
41 sformatowany znacznik VCS i wydobędzie z niego numer wersji.
42
43 %package -n python3-vcversioner
44 Summary:        Use version control tags to discover version numbers
45 Summary(pl.UTF-8):      Użycie znaczników kontroli wersji do wykrywania numerów wersji
46 Group:          Libraries/Python
47 Requires:       python3-modules >= 1:3.3
48
49 %description -n python3-vcversioner
50 This module allows you to write a setup.py with no version information
51 specified, and vcversioner will find a recent, properly-formatted VCS
52 tag and extract a version from it.
53
54 %description -n python3-vcversioner -l pl.UTF-8
55 Ten moduł pozwala na tworzenie plików setup.py nie zawierających
56 informacji o wersji; vcversioner znajdzie najnowszy, właściwie
57 sformatowany znacznik VCS i wydobędzie z niego numer wersji.
58
59 %prep
60 %setup -q -n vcversioner-%{version}
61
62 %build
63 %if %{with python2}
64 %py_build
65 %endif
66
67 %if %{with python3}
68 %py3_build
69 %endif
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %if %{with python2}
75 %py_install
76
77 %py_postclean
78 %endif
79
80 %if %{with python3}
81 %py3_install
82 %endif
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %if %{with python2}
88 %files
89 %defattr(644,root,root,755)
90 %doc README.rst
91 %{py_sitescriptdir}/vcversioner.py[co]
92 %{py_sitescriptdir}/vcversioner-%{version}-py*.egg-info
93 %endif
94
95 %if %{with python3}
96 %files -n python3-vcversioner
97 %defattr(644,root,root,755)
98 %doc README.rst
99 %{py3_sitescriptdir}/vcversioner.py
100 %{py3_sitescriptdir}/__pycache__/vcversioner.cpython-*.py[co]
101 %{py3_sitescriptdir}/vcversioner-%{version}-py*.egg-info
102 %endif
This page took 0.560492 seconds and 2 git commands to generate.