]> git.pld-linux.org Git - packages/python-unittest-xml-reporting.git/blob - python-unittest-xml-reporting.spec
f29b92dc7d256ea51a88c51c9ac33216b4fbb45e
[packages/python-unittest-xml-reporting.git] / python-unittest-xml-reporting.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  unittest-xml-reporting
7 Summary:        Unittest-based test runner with Ant/JUnit like XML reporting
8 Name:           python-%{module}
9 Version:        2.1.0
10 Release:        6
11 License:        BSD
12 Group:          Libraries/Python
13 Source0:        https://pypi.python.org/packages/77/27/b4442a041de8fc5366e3d0c82fa2919cba76d6fc7888635540828c740633/%{module}-%{version}.tar.gz
14 # Source0-md5:  9284cbfccc56b4347493f134e780fa3c
15 URL:            http://github.com/danielfm/unittest-xml-reporting/tree/master/
16 BuildRequires:  rpmbuild(macros) >= 1.714
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.7
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python2}
22 BuildRequires:  python3-modules >= 1:3.3
23 BuildRequires:  python3-setuptools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 Requires:       python-modules >= 1:2.7
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 unittest-xml-reporting is a unittest test runner that can save test
32 results to XML files that can be consumed by a wide range of tools,
33 such as build systems, IDEs and continuous integration servers.
34
35 %package -n python3-%{module}
36 Summary:        Unittest-based test runner with Ant/JUnit like XML reporting
37 Group:          Libraries/Python
38 Requires:       python3-modules
39
40 %description -n python3-%{module}
41 unittest-xml-reporting is a unittest test runner that can save test
42 results to XML files that can be consumed by a wide range of tools,
43 such as build systems, IDEs and continuous integration servers.
44
45 %prep
46 %setup -q -n %{module}-%{version}
47
48 %build
49 %if %{with python2}
50 %py_build %{?with_tests:test}
51 %endif
52
53 %if %{with python3}
54 %py3_build %{?with_tests:test}
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %if %{with python2}
61 %py_install
62
63 %py_postclean
64 %endif
65
66 %if %{with python3}
67 %py3_install
68 %endif
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc PKG-INFO
76 %{py_sitescriptdir}/unittest_xml_report*egg-info
77 %{py_sitescriptdir}/xmlrunner
78
79 %files -n python3-%{module}
80 %defattr(644,root,root,755)
81 %doc PKG-INFO
82 %{py3_sitescriptdir}/unittest_xml_report*egg-info
83 %{py3_sitescriptdir}/xmlrunner
This page took 0.046099 seconds and 2 git commands to generate.