]> git.pld-linux.org Git - packages/python-unicodedata2.git/blob - python-unicodedata2.spec
2a36a87940d498bf6f4a7527b42f3de9c130c6b9
[packages/python-unicodedata2.git] / python-unicodedata2.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Unicodedata backport/updates to Python 2.x
7 Summary(pl.UTF-8):      Uaktualnienia danych Unicode dla Pythona 2.x
8 Name:           python-unicodedata2
9 Version:        12.1.0
10 Release:        3
11 License:        Apache v2.0
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/unicodedata2/
14 Source0:        https://files.pythonhosted.org/packages/source/u/unicodedata2/unicodedata2-%{version}.tar.gz
15 # Source0-md5:  a4d781b0d59a8cb9243d4a84aa10fbd9
16 URL:            https://pypi.org/project/unicodedata2/
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 %if %{with python2}
20 BuildRequires:  python-devel >= 2.0
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-devel >= 1:3.2
25 BuildRequires:  python3-setuptools
26 %endif
27 Requires:       python-libs >= 2.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Unicodedata backport/updates to Python 2.x.
32
33 Additionally this module backports named aliases and named sequences
34 support to Python 2.
35
36 %description -l pl.UTF-8
37 Uaktualnienia danych Unicode dla Pythona 2.x.
38
39 Dodatkowo ten moduł zawiera backport nazwanych aliasów i nazwanych
40 sekwencji do Pythona 2.
41
42 %package -n python3-unicodedata2
43 Summary:        Unicodedata backport/updates to Python 3.x
44 Summary(pl.UTF-8):      Uaktualnienia danych Unicode dla Pythona 3.x
45 Group:          Libraries/Python
46 Requires:       python3-libs >= 1:3.2
47
48 %description -n python3-unicodedata2
49 Unicodedata backport/updates to Python 3.x.
50
51 %description -n python3-unicodedata2 -l pl.UTF-8
52 Uaktualnienia danych Unicode dla Pythona 3.x.
53
54 %prep
55 %setup -q -n unicodedata2-%{version}
56
57 %build
58 %if %{with python2}
59 %py_build
60 %endif
61
62 %if %{with python3}
63 %py3_build
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %if %{with python2}
70 %py_install
71
72 %py_postclean
73 %endif
74
75 %if %{with python3}
76 %py3_install
77 %endif
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %if %{with python2}
83 %files
84 %defattr(644,root,root,755)
85 %doc README.md
86 %attr(755,root,root) %{py_sitedir}/unicodedata2.so
87 %{py_sitedir}/unicodedata2-%{version}-py*.egg-info
88 %endif
89
90 %if %{with python3}
91 %files -n python3-unicodedata2
92 %defattr(644,root,root,755)
93 %doc README.md
94 %attr(755,root,root) %{py3_sitedir}/unicodedata2.cpython-*.so
95 %{py3_sitedir}/unicodedata2-%{version}-py*.egg-info
96 %endif
This page took 0.094361 seconds and 2 git commands to generate.