]> git.pld-linux.org Git - packages/python-unicodecsv.git/blob - python-unicodecsv.spec
- release 2 (by relup.sh)
[packages/python-unicodecsv.git] / python-unicodecsv.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do perform "make test" (broken, will download dependecies)
4
5 %define         module  unicodecsv
6 Summary:        Replacement for csv module which supports unicode strings without a hassle
7 Name:           python-%{module}
8 Version:        0.14.0
9 Release:        2
10 License:        BSD
11 Group:          Development/Languages/Python
12 Source0:        http://pypi.python.org/packages/source/u/unicodecsv/%{module}-%{version}.tar.gz
13 # Source0-md5:  ae2aaff1c2de7b15c741ac394f75a429
14 URL:            https://github.com/jdunck/python-unicodecsv
15 BuildRequires:  python-setuptools
16 BuildRequires:  rpmbuild(macros) >= 1.710
17 BuildRequires:  rpm-pythonprov
18 Requires:       python-modules
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The unicodecsv is a drop-in replacement for Python 2's csv module
24 which supports unicode strings without a hassle.
25
26 %prep
27 %setup -q -n %{module}-%{version}
28
29 %build
30 %py_build %{?with_tests:test}
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 %py_install
36
37 %py_postclean
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %doc README.rst
45 %dir %{py_sitescriptdir}/%{module}
46 %{py_sitescriptdir}/%{module}/*.py[co]
47 %{py_sitescriptdir}/%{module}-*.egg-info
This page took 0.101778 seconds and 3 git commands to generate.