]> git.pld-linux.org Git - packages/python-u2flib-server.git/blob - python-u2flib-server.spec
rebuild with tests and docs
[packages/python-u2flib-server.git] / python-u2flib-server.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Python 2 based U2F server library
8 Summary(pl.UTF-8):      Biblioteka serwera U2F dla Pythona 2
9 Name:           python-u2flib-server
10 Version:        5.0.0
11 Release:        6
12 License:        BSD
13 Group:          Libraries/Python
14 Source0:        https://developers.yubico.com/python-u2flib-server/Releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  c87bc9984adf96e97aa35323dfc1edd4
16 URL:            https://developers.yubico.com/python-u2flib-server/
17 BuildRequires:  asciidoc
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 BuildRequires:  python-setuptools
23 %if %{with tests}
24 BuildRequires:  python-cryptography >= 1.2
25 BuildRequires:  python-enum34
26 BuildRequires:  python-six
27 %endif
28 %endif
29 %if %{with python3}
30 BuildRequires:  python3-modules >= 1:3.3
31 BuildRequires:  python3-setuptools
32 %if %{with tests}
33 BuildRequires:  python3-cryptography >= 1.2
34 BuildRequires:  python3-six
35 %endif
36 %endif
37 Requires:       python-modules >= 1:2.7
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Provides functionality for working with the server side aspects of the
43 U2F protocol as defined in FIDO specifications
44 (<http://fidoalliance.org/specifications/download>).
45
46 %description -l pl.UTF-8
47 Pakiet zawiera funkcje obsługujące serwerowe aspekty protokołu U2F
48 zdefiniowane w specyfikacji FIDO
49 (<http://fidoalliance.org/specifications/download>).
50
51 %package -n python3-u2flib-server
52 Summary:        Python 3 based U2F server library
53 Summary(pl.UTF-8):      Biblioteka serwera U2F dla Pythona 3
54 Group:          Libraries/Python
55 Requires:       python3-modules >= 1:3.3
56
57 %description -n python3-u2flib-server
58 Provides functionality for working with the server side aspects of the
59 U2F protocol as defined in FIDO specifications
60 (<http://fidoalliance.org/specifications/download>).
61
62 %description -n python3-u2flib-server -l pl.UTF-8
63 Pakiet zawiera funkcje obsługujące serwerowe aspekty protokołu U2F
64 zdefiniowane w specyfikacji FIDO
65 (<http://fidoalliance.org/specifications/download>).
66
67 %prep
68 %setup -q
69
70 %build
71 %if %{with python2}
72 %py_build %{?with_tests:test}
73 %endif
74
75 %if %{with python3}
76 %py3_build %{?with_tests:test}
77 %endif
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %if %{with python2}
83 %py_install
84
85 %py_postclean
86 %endif
87
88 %if %{with python3}
89 %py3_install
90 %endif
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %if %{with python2}
96 %files
97 %defattr(644,root,root,755)
98 %doc COPYING ChangeLog NEWS README
99 %{py_sitescriptdir}/u2flib_server
100 %{py_sitescriptdir}/python_u2flib_server-%{version}-py*.egg-info
101 %endif
102
103 %if %{with python3}
104 %files -n python3-u2flib-server
105 %defattr(644,root,root,755)
106 %doc COPYING ChangeLog NEWS README
107 %{py3_sitescriptdir}/u2flib_server
108 %{py3_sitescriptdir}/python_u2flib_server-%{version}-py*.egg-info
109 %endif
This page took 0.04495 seconds and 3 git commands to generate.