]> git.pld-linux.org Git - packages/python-tox.git/blob - python-tox.spec
rel.3 Tests need fixing when run on builders.
[packages/python-tox.git] / python-tox.spec
1 # TODO:
2 # - packaging of
3 #        /usr/bin/tox
4 #        /usr/bin/tox-quickstart
5 # - fix tests on builders
6
7 # Conditional build:
8 %bcond_without  tests   # do not perform "make test"
9 %bcond_without  python2 # CPython 2.x module
10 %bcond_without  python3 # CPython 3.x module
11
12 %define         module  tox
13 Summary:        Virtualenv-based automation of test activities
14 Summary(pl.UTF-8):      Oparta na Virtualenv automatyka testów
15 Name:           python-%{module}
16 Version:        2.3.1
17 Release:        3
18 License:        MIT
19 Group:          Libraries/Python
20 Source0:        https://pypi.python.org/packages/46/39/e15a857fda1852da1485bc88ac4268dbcef037ab526e1ac21accf2a5c24c/tox-%{version}.tar.gz
21 # Source0-md5:  9371b3d3e25c03751a0372e19602dfb9
22 URL:            http://tox.testrun.org/
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 %if %{with python2}
26 BuildRequires:  python-modules
27 BuildRequires:  python-pluggy
28 BuildRequires:  python-virtualenv
29 BuildRequires:  python-pytest >= 2.3.5
30 BuildRequires:  python-pytest-timeout
31 BuildRequires:  python-py
32 %endif
33 %if %{with python3}
34 BuildRequires:  python3-modules
35 BuildRequires:  python3-pluggy
36 BuildRequires:  python3-virtualenv
37 BuildRequires:  python3-pytest >= 2.3.5
38 BuildRequires:  python3-pytest-timeout
39 BuildRequires:  python3-py
40 %endif
41 Requires:       python-modules
42 BuildArch:      noarch
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Tox is a generic virtualenv management and test command line tool you
47 can use for:
48 - checking your package installs correctly with different Python
49   versions and interpreters
50 - running your tests in each of the environments, configuring your
51   test tool of choice
52 - acting as a frontend to Continuous Integration servers, greatly
53   reducing boilerplate and merging CI and shell-based testing.
54
55 %description -l pl.UTF-8
56 Tox jest ogólnym, operatym na virtualenv narzędziem linii poleceń
57 które może być użyte do:
58 - testowania czy pakiet instaluje się poprawnie z róznymi wersjami
59   Pythona
60 - uruchamionia testów dla każdego ze środowisk, konfigurując narzędzia
61   testowe
62 - jako frontend dla serwerów Continuous Integration,
63
64 %package -n python3-%{module}
65 Summary:        Virtualenv-based automation of test activities
66 Summary(pl.UTF-8):      Oparta na Virtualenv automatyka testów
67 Group:          Libraries/Python
68 Requires:       python3-modules
69
70 %description -n python3-%{module}
71 Tox is a generic virtualenv management and test command line tool you
72 can use for:
73 - checking your package installs correctly with different Python
74   versions and interpreters
75 - running your tests in each of the environments, configuring your
76   test tool of choice
77 - acting as a frontend to Continuous Integration servers, greatly
78   reducing boilerplate and merging CI and shell-based testing.
79
80 %description -n python3-%{module} -l pl.UTF-8
81 Tox jest ogólnym, operatym na virtualenv narzędziem linii poleceń
82 które może być użyte do:
83 - testowania czy pakiet instaluje się poprawnie z róznymi wersjami
84   Pythona
85 - uruchamionia testów dla każdego ze środowisk, konfigurując narzędzia
86   testowe
87 - jako frontend dla serwerów Continuous Integration,
88
89 %package apidocs
90 Summary:        %{module} API documentation
91 Summary(pl.UTF-8):      Dokumentacja API %{module}
92 Group:          Documentation
93
94 %description apidocs
95 API documentation for %{module}.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API %{module}.
99
100 %prep
101 %setup -q -n %{module}-%{version}
102
103 %build
104 %if %{with python2}
105 %py_build %{?with_tests:test}
106 %endif
107
108 %if %{with python3}
109 %py3_build %{?with_tests:test}
110 %endif
111
112 %if %{with doc}
113 cd docs
114 %{__make} -j1 html
115 rm -rf _build/html/_sources
116 %endif
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 %if %{with python2}
121 %py_install
122 %py_postclean
123 %endif
124
125 %if %{with python3}
126 %py3_install
127 %endif
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %if %{with python2}
133 %files
134 %defattr(644,root,root,755)
135 %doc CHANGELOG CONTRIBUTORS ISSUES.txt README.rst
136 %attr(755,root,root) %{_bindir}/tox
137 %attr(755,root,root) %{_bindir}/tox-quickstart
138 %{py_sitescriptdir}/%{module}
139 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
140 %endif
141
142 %if %{with python3}
143 %files -n python3-%{module}
144 %defattr(644,root,root,755)
145 %doc CHANGELOG CONTRIBUTORS ISSUES.txt README.rst
146 %{py3_sitescriptdir}/%{module}
147 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
148 %endif
149
150 %if %{with doc}
151 %files apidocs
152 %defattr(644,root,root,755)
153 %doc docs/_build/html/*
154 %endif
This page took 0.061879 seconds and 3 git commands to generate.