]> git.pld-linux.org Git - packages/python-texext.git/blob - python-texext.spec
a773089f47a140048659e72374699c221ac7974c
[packages/python-texext.git] / python-texext.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Sphinx extensions for working with LaTeX math
8 Summary(pl.UTF-8):      Rozszerzenia Sphinksa do pracy z LaTeXowymi wzorami matematycznymi
9 Name:           python-texext
10 Version:        0.6.1
11 Release:        1
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/texext/
15 Source0:        https://files.pythonhosted.org/packages/source/t/texext/texext-%{version}.tar.gz
16 # Source0-md5:  a8bf2d509afdbc1307a0e7bfc4bd3eaf
17 URL:            https://pypi.org/project/texext/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-Sphinx >= 1.3.1
23 BuildRequires:  python-pytest
24 BuildRequires:  python-six
25 BuildRequires:  python-sympy
26 %endif
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-modules >= 1:3.3
30 BuildRequires:  python3-setuptools
31 %if %{with tests}
32 BuildRequires:  python3-Sphinx >= 1.3.1
33 BuildRequires:  python3-pytest
34 BuildRequires:  python3-six
35 BuildRequires:  python3-sympy
36 %endif
37 %endif
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  rpmbuild(macros) >= 1.714
40 Requires:       python-modules >= 1:2.7
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 texext contains a couple of Sphinx extensions for working with LaTeX
46 math.
47
48 %description -l pl.UTF-8
49 texext zawiera kilka rozszerzeń Sphinksa do pracy z LaTeXowymi wzorami
50 matematycznymi.
51
52 %package -n python3-texext
53 Summary:        Sphinx extensions for working with LaTeX math
54 Summary(pl.UTF-8):      Rozszerzenia Sphinksa do pracy z LaTeXowymi wzorami matematycznymi
55 Group:          Libraries/Python
56 Requires:       python3-modules >= 1:3.3
57
58 %description -n python3-texext
59 texext contains a couple of Sphinx extensions for working with LaTeX
60 math.
61
62 %description -n python3-texext -l pl.UTF-8
63 texext zawiera kilka rozszerzeń Sphinksa do pracy z LaTeXowymi wzorami
64 matematycznymi.
65
66 %prep
67 %setup -q -n texext-%{version}
68
69 %build
70 %if %{with python2}
71 %py_build
72
73 %if %{with tests}
74 PYTHONPATH=$(pwd)/build-2/lib \
75 %{__python} -m pytest texext/tests
76 %endif
77 %endif
78
79 %if %{with python3}
80 %py3_build
81
82 %if %{with tests}
83 PYTHONPATH=$(pwd)/build-2/lib \
84 %{__python3} -m pytest texext/tests
85 %endif
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %if %{with python2}
92 %py_install
93
94 %py_postclean
95 %endif
96
97 %if %{with python3}
98 %py3_install
99 %endif
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %if %{with python2}
105 %files
106 %defattr(644,root,root,755)
107 %doc LICENSE README.rst
108 %{py_sitescriptdir}/texext
109 %{py_sitescriptdir}/texext-%{version}-py*.egg-info
110 %endif
111
112 %if %{with python3}
113 %files -n python3-texext
114 %defattr(644,root,root,755)
115 %doc LICENSE README.rst
116 %{py3_sitescriptdir}/texext
117 %{py3_sitescriptdir}/texext-%{version}-py*.egg-info
118 %endif
This page took 0.027403 seconds and 2 git commands to generate.