]> git.pld-linux.org Git - packages/python-texext.git/blob - python-texext.spec
4f78d031325bd86f83d638a32500f6d919750f8f
[packages/python-texext.git] / python-texext.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Sphinx extensions for working with LaTeX math
8 Summary(pl.UTF-8):      Rozszerzenia Sphinksa do pracy z LaTeXowymi wzorami matematycznymi
9 Name:           python-texext
10 Version:        0.6.5
11 Release:        2
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/texext/
15 Source0:        https://files.pythonhosted.org/packages/source/t/texext/texext-%{version}.tar.gz
16 # Source0-md5:  4f86a0cd2e75f1779b713b8342c7cdc6
17 URL:            https://pypi.org/project/texext/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-Sphinx >= 1.3.1
23 BuildRequires:  python-docutils >= 0.12
24 BuildRequires:  python-matplotlib >= 1.4.3
25 BuildRequires:  python-pytest
26 BuildRequires:  python-six >= 1.4.0
27 BuildRequires:  python-sphinxtesters >= 0.2
28 BuildRequires:  python-sympy >= 0.7
29 %endif
30 %endif
31 %if %{with python3}
32 BuildRequires:  python3-modules >= 1:3.4
33 BuildRequires:  python3-setuptools
34 %if %{with tests}
35 BuildRequires:  python3-Sphinx >= 1.3.1
36 BuildRequires:  python3-docutils >= 0.12
37 BuildRequires:  python3-matplotlib >= 1.4.3
38 BuildRequires:  python3-pytest
39 BuildRequires:  python3-six >= 1.4.0
40 BuildRequires:  python3-sphinxtesters >= 0.2
41 BuildRequires:  python3-sympy >= 0.7
42 %endif
43 %endif
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  rpmbuild(macros) >= 1.714
46 Requires:       python-modules >= 1:2.7
47 BuildArch:      noarch
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 texext contains a couple of Sphinx extensions for working with LaTeX
52 math.
53
54 %description -l pl.UTF-8
55 texext zawiera kilka rozszerzeń Sphinksa do pracy z LaTeXowymi wzorami
56 matematycznymi.
57
58 %package -n python3-texext
59 Summary:        Sphinx extensions for working with LaTeX math
60 Summary(pl.UTF-8):      Rozszerzenia Sphinksa do pracy z LaTeXowymi wzorami matematycznymi
61 Group:          Libraries/Python
62 Requires:       python3-modules >= 1:3.4
63
64 %description -n python3-texext
65 texext contains a couple of Sphinx extensions for working with LaTeX
66 math.
67
68 %description -n python3-texext -l pl.UTF-8
69 texext zawiera kilka rozszerzeń Sphinksa do pracy z LaTeXowymi wzorami
70 matematycznymi.
71
72 %prep
73 %setup -q -n texext-%{version}
74
75 %build
76 %if %{with python2}
77 %py_build
78
79 %if %{with tests}
80 PYTHONPATH=$(pwd)/build-2/lib \
81 %{__python} -m pytest texext/tests
82 %endif
83 %endif
84
85 %if %{with python3}
86 %py3_build
87
88 %if %{with tests}
89 PYTHONPATH=$(pwd)/build-2/lib \
90 %{__python3} -m pytest texext/tests
91 %endif
92 %endif
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %if %{with python2}
98 %py_install
99
100 %py_postclean
101 %endif
102
103 %if %{with python3}
104 %py3_install
105 %endif
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %if %{with python2}
111 %files
112 %defattr(644,root,root,755)
113 %doc LICENSE README.rst
114 %{py_sitescriptdir}/texext
115 %{py_sitescriptdir}/texext-%{version}-py*.egg-info
116 %endif
117
118 %if %{with python3}
119 %files -n python3-texext
120 %defattr(644,root,root,755)
121 %doc LICENSE README.rst
122 %{py3_sitescriptdir}/texext
123 %{py3_sitescriptdir}/texext-%{version}-py*.egg-info
124 %endif
This page took 0.064322 seconds and 2 git commands to generate.