]> git.pld-linux.org Git - packages/python-testrepository.git/blob - python-testrepository.spec
- python 3.6
[packages/python-testrepository.git] / python-testrepository.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # testr (python 2 only because of bzr dependency, broken as of 0.0.20)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        A repository of test results
8 Summary(pl.UTF-8):      Repozytorium wyników testów
9 Name:           python-testrepository
10 Version:        0.0.20
11 Release:        2
12 License:        Apache v2.0 or BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/simple/testrepository/
15 Source0:        https://pypi.python.org/packages/source/t/testrepository/testrepository-%{version}.tar.gz
16 # Source0-md5:  f648b0aceeca4fcd5f8a62eeedea289b
17 URL:            https://launchpad.net/testrepository
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.6
22 BuildRequires:  python-setuptools
23 %if %{with tests}
24 BuildRequires:  python-bzr
25 BuildRequires:  python-pytz
26 BuildRequires:  python-testresources
27 BuildRequires:  python-testscenarios
28 %endif
29 %endif
30 %if %{with python3}
31 BuildRequires:  python3-modules >= 1:3.2
32 BuildRequires:  python3-setuptools
33 # no bzr for python3, so no tests
34 %if %{with python3_tests}
35 BuildRequires:  python3-bzr
36 BuildRequires:  python3-pytz
37 BuildRequires:  python3-testresources
38 BuildRequires:  python3-testscenarios
39 %endif
40 %endif
41 Requires:       python-fixtures
42 Requires:       python-modules >= 1:2.6
43 Requires:       python-subunit >= 0.0.18
44 Requires:       python-testtools >= 0.9.30
45 BuildArch:      noarch
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 This project provides a database of test results which can be used as
50 part of developer workflow to ensure/check things like:
51 - No commits without having had a test failure, test fixed cycle.
52 - No commits without new tests being added.
53 - What tests have failed since the last commit (to run just a subset).
54 - What tests are currently failing and need work.
55
56 Test results are inserted using subunit (and thus anything that can
57 output subunit or be converted into a subunit stream can be accepted).
58
59 %description -l pl.UTF-8
60 Ten projekt zapewnia bazę danych wyników testów, które można używać
61 jako część ciągu pracy programistów, mającą na celu
62 zapewnienie/sprawdzenie, że:
63 - nie wejdą zmiany bez naprawienia nieprzechodzących testów
64 - nie wejdą zmiany bez dodania nowych testów
65 - które testy nie powiodły się od ostatnich zmian (aby uruchomić
66   podzbiór)
67 - które testy obecnie nie przechodzą i wymagają pracy
68
69 Wyniki testów są wprowadzane przy użyciu modułu subunit (więc może być
70 przyjęte wszystko, co na wyjściu ma format subunit albo może być
71 przekonwertowane do takiego strumienia).
72
73 %package -n python3-testrepository
74 Summary:        A repository of test results
75 Summary(pl.UTF-8):      Repozytorium wyników testów
76 Group:          Libraries/Python
77 Requires:       python3-fixtures
78 Requires:       python3-modules >= 1:3.2
79 Requires:       python3-subunit >= 0.0.18
80 Requires:       python3-testtools >= 0.9.30
81
82 %description -n python3-testrepository
83 This project provides a database of test results which can be used as
84 part of developer workflow to ensure/check things like:
85 - No commits without having had a test failure, test fixed cycle.
86 - No commits without new tests being added.
87 - What tests have failed since the last commit (to run just a subset).
88 - What tests are currently failing and need work.
89
90 Test results are inserted using subunit (and thus anything that can
91 output subunit or be converted into a subunit stream can be accepted).
92
93 %description -n python3-testrepository -l pl.UTF-8
94 Ten projekt zapewnia bazę danych wyników testów, które można używać
95 jako część ciągu pracy programistów, mającą na celu
96 zapewnienie/sprawdzenie, że:
97 - nie wejdą zmiany bez naprawienia nieprzechodzących testów
98 - nie wejdą zmiany bez dodania nowych testów
99 - które testy nie powiodły się od ostatnich zmian (aby uruchomić
100   podzbiór)
101 - które testy obecnie nie przechodzą i wymagają pracy
102
103 Wyniki testów są wprowadzane przy użyciu modułu subunit (więc może być
104 przyjęte wszystko, co na wyjściu ma format subunit albo może być
105 przekonwertowane do takiego strumienia).
106
107 %prep
108 %setup -q -n testrepository-%{version}
109
110 %build
111 %if %{with python2}
112 %py_build
113 %{?with_tests:%{__python} testr init && %{__python} testr run --parallel}
114 %endif
115
116 %if %{with python3}
117 %py3_build %{?with_tests:test}
118 %{?with_python3_tests:%{__python3} testr init && %{__python3} testr run --parallel}
119 %endif
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %if %{with python2}
125 %py_install
126 %{__mv} $RPM_BUILD_ROOT%{_bindir}/testr{,-2}
127
128 %py_postclean
129 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/testrepository/tests
130 %endif
131
132 %if %{with python3}
133 %py3_install
134 %{__mv} $RPM_BUILD_ROOT%{_bindir}/testr{,-3}
135
136 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/testrepository/tests
137 %endif
138
139 %if %{with python2}
140 ln -sf testr-2 $RPM_BUILD_ROOT%{_bindir}/testr
141 %endif
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %if %{with python2}
147 %files
148 %defattr(644,root,root,755)
149 %doc BSD COPYING NEWS README.txt doc
150 %attr(755,root,root) %{_bindir}/testr
151 %attr(755,root,root) %{_bindir}/testr-2
152 %{py_sitescriptdir}/testrepository
153 %{py_sitescriptdir}/testrepository-%{version}-py*.egg-info
154 %endif
155
156 %if %{with python3}
157 %files -n python3-testrepository
158 %defattr(644,root,root,755)
159 %doc BSD COPYING NEWS README.txt doc
160 %attr(755,root,root) %{_bindir}/testr-3
161 %{py3_sitescriptdir}/testrepository
162 %{py3_sitescriptdir}/testrepository-%{version}-py*.egg-info
163 %endif
This page took 0.056846 seconds and 3 git commands to generate.