]> git.pld-linux.org Git - packages/python-tables.git/blob - python-tables.spec
- converted to UTF-8
[packages/python-tables.git] / python-tables.spec
1
2 %define         module  tables
3
4 Summary:        Dealing with large datasets in Python
5 Summary(pl.UTF-8):   Obsługa dużych zbiorów danych w Pythonie
6 Name:           python-%{module}
7 Version:        1.2.1
8 Release:        1
9 License:        GNU
10 Group:          Development/Languages/Python
11 Source0:        http://dl.sourceforge.net/pytables/pytables-%{version}.tar.gz
12 # Source0-md5:  0fb331822f27e3cb03d04bd4247e8032
13 URL:            http://pytables.sourceforge.net/
14 BuildRequires:  hdf5-devel
15 BuildRequires:  lzo-devel
16 BuildRequires:  python
17 BuildRequires:  python-devel >= 1:2.3
18 BuildRequires:  python-numarray
19 BuildRequires:  python-numarray-devel
20 BuildRequires:  ucl-devel
21 %pyrequires_eq  python-modules
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 PyTables is a hierarchical database package designed to efficiently
26 manage very large amounts of data.
27
28 PyTables is built on top of the HDF5 library and the numarray package.
29 It features an object-oriented interface that, combined with C
30 extensions for the peformance-critical parts of the code (generated
31 using Pyrex), makes it a fast, yet extremely easy to use tool for
32 interactively save and retrieve very large amounts of data. One
33 important feature of PyTables is that it optimizes memory and disk
34 resources so that data take much less space (between a factor 3 to 5,
35 and more if the data is compressible) than other solutions, like for
36 example, relational or object oriented databases.
37
38 Besides, it provides a flexible, direct access on disk to anywhere in
39 the data you want to go, using a combination of natural naming and
40 extended slicing features.
41
42 %description -l pl.UTF-8
43 PyTables jest hierarchiczną bazą danych zaprojektowaną aby wydajnie
44 zarządzać bardzo dużymi ilościami danych.
45
46 PyTables jest zbudowany w oparciu o bibliotekę HDF5 i pakiet numarray.
47 Zapewnia zorientowany obiektowo interfejs, dzięki któremu, w
48 połączeniu z przepisanymi do C krytycznymi częściami kodu, pozwala na
49 bardzo szybkie i łatwe używanie tego narzędzia do interaktywnego
50 zapisu lub odczytu dużych ilości danych. Jedną z ważniejszych zalet
51 PyTables jest optymalizacja zużycia pamięci i przestrzeni dyskowej.
52
53 %prep
54 %setup -q -n pytables-%{version}
55
56 %build
57 CFLAGS="%{rpmcflags}"
58 export CFLAGS
59 python setup.py build_ext --inplace
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 python setup.py install \
67         --root=$RPM_BUILD_ROOT \
68         --optimize=2
69
70 mv examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71
72 find $RPM_BUILD_ROOT%{py_sitedir} -name '*.py' | xargs rm
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc README.txt LICENSE
80 %attr(755,root,root) %{_bindir}/*
81 %dir %{py_sitedir}/%{module}
82 %{py_sitedir}/%{module}/*
83 %dir %{_examplesdir}/%{name}-%{version}
84 %{_examplesdir}/%{name}-%{version}/*
This page took 0.0591 seconds and 3 git commands to generate.