]> git.pld-linux.org Git - packages/python-sqlite.git/blob - python-sqlite.spec
build with pythonegg provides
[packages/python-sqlite.git] / python-sqlite.spec
1 %define         module  sqlite
2 Summary:        A DB API v2.0 compatible interface to SQLite
3 Summary(pl.UTF-8):      Interfejs do SQLite kompatybilny z DB API v2.0
4 Name:           python-%{module}
5 Version:        2.6.3
6 Release:        2
7 License:        zlib/libpng
8 Group:          Development/Languages/Python
9 Source0:        http://pysqlite.googlecode.com/files/pysqlite-%{version}.tar.gz
10 # Source0-md5:  711afa1062a1d2c4a67acdf02a33d86e
11 URL:            http://pysqlite.googlecode.com/
12 BuildRequires:  python-devel >= 1:2.5
13 BuildRequires:  python-modules
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  sqlite3-devel >= 3.6.11
16 Requires:       python-modules
17 Provides:       python(sqlite)
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This is an extension module for the SQLite embedded relational
22 database. It tries to conform to the Python DB-API Spec v2 as far as
23 possible. One problem is that SQLite returns everything as text. This
24 is a result of SQLite's internal representation of data, however it
25 still may be possible to return data in the type specified by the
26 table definitions.
27
28 %description -l pl.UTF-8
29 Ten pakiet zawiera moduł rozszerzenia dla osadzalnej relacyjnej bazy
30 danych SQLite. Próbuje on być w zgodzie ze specyfikacją Python DB-API
31 v2 na tyle, na ile to możliwe. Jednym problemem jest to, że SQLite
32 zwraca wszystko jako tekst. Jest to wynik wewnętrznej reprezentacji
33 danych przez SQLite; mimo to nadal jest możliwe zwracanie danych typu
34 podanego w definicji tabeli.
35
36 %prep
37 %setup -q -n pysqlite-%{version}
38
39 %build
40 CFLAGS="%{rpmcflags}" \
41 %{__python} setup.py build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
46
47 PYTHONPATH=$RPM_BUILD_ROOT%{py_sitedir} \
48         %{__python} setup.py install \
49         --optimize=2 \
50         --root=$RPM_BUILD_ROOT
51
52 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/pysqlite2/test/py25
53 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/pysqlite2/{,test/}*.py \
54         $RPM_BUILD_ROOT%{_prefix}/pysqlite2-doc
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc doc/*.txt
62 %dir %{py_sitedir}/pysqlite2
63 %{py_sitedir}/*.egg-info
64 %{py_sitedir}/pysqlite2/*.py[co]
65 %attr(755,root,root) %{py_sitedir}/pysqlite2/_%{module}.so
66 %dir %{py_sitedir}/pysqlite2/test
67 %{py_sitedir}/pysqlite2/test/*.py[co]
This page took 0.117347 seconds and 3 git commands to generate.