]> git.pld-linux.org Git - packages/python-sphinxcontrib-bitbucket.git/blob - python-sphinxcontrib-bitbucket.spec
use epoch 1 for python3 package
[packages/python-sphinxcontrib-bitbucket.git] / python-sphinxcontrib-bitbucket.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Sphinx/BitBucket integration module for Python 2
7 Summary(pl.UTF-8):      Moduł integrujący Sphinx/BitBucket dla Pythona 2
8 Name:           python-sphinxcontrib-bitbucket
9 Version:        1.0
10 Release:        2
11 License:        BSD
12 Group:          Libraries/Python
13 Source0:        https://files.pythonhosted.org/packages/source/s/sphinxcontrib-bitbucket/sphinxcontrib-bitbucket-%{version}.tar.gz
14 # Source0-md5:  129147d406087e44769ae7320a2d839b
15 Patch0:         %{name}-py3.patch
16 URL:            http://www.doughellmann.com/projects/sphinxcontrib-bitbucket/
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 %if %{with python2}
20 BuildRequires:  python-modules >= 2
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules >= 1:3
25 BuildRequires:  python3-setuptools
26 %endif
27 Requires:       python-modules >= 2
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This module adds custom roles for linking to resources on BitBucket
33 projects.
34
35 %description -l pl.UTF-8
36 Ten moduł dodaje własne role, pozwalające na dowiązywanie do zasobów
37 projektów na serwisie BitBucket.
38
39 %package -n python3-sphinxcontrib-bitbucket
40 Summary:        Sphinx/BitBucket integration module for Python 3
41 Summary(pl.UTF-8):      Moduł integrujący Sphinx/BitBucket dla Pythona 3
42 Group:          Libraries/Python
43 Requires:       python3-modules >= 3
44
45 %description -n python3-sphinxcontrib-bitbucket
46 This module adds custom roles for linking to resources on BitBucket
47 projects.
48
49 %description -n python3-sphinxcontrib-bitbucket -l pl.UTF-8
50 Ten moduł dodaje własne role, pozwalające na dowiązywanie do zasobów
51 projektów na serwisie BitBucket.
52
53 %prep
54 %setup -q -n sphinxcontrib-bitbucket-%{version}
55 %patch -p1
56
57 %build
58 %if %{with python2}
59 %py_build
60 %endif
61
62 %if %{with python3}
63 %py3_build
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %if %{with python2}
70 %py_install
71
72 %py_postclean
73 %endif
74
75 %if %{with python3}
76 %py3_install
77 %endif
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %if %{with python2}
83 %files
84 %defattr(644,root,root,755)
85 %doc LICENSE README
86 # XXX: shared dir
87 %dir %{py_sitescriptdir}/sphinxcontrib
88 %{py_sitescriptdir}/sphinxcontrib/bitbucket.py[co]
89 %{py_sitescriptdir}/sphinxcontrib_bitbucket-%{version}-py*.egg-info
90 %{py_sitescriptdir}/sphinxcontrib_bitbucket-%{version}-py*-nspkg.pth
91 %endif
92
93 %if %{with python3}
94 %files -n python3-sphinxcontrib-bitbucket
95 %defattr(644,root,root,755)
96 %doc LICENSE README
97 # XXX: shared dirs
98 %dir %{py3_sitescriptdir}/sphinxcontrib
99 %dir %{py3_sitescriptdir}/sphinxcontrib/__pycache__
100 %{py3_sitescriptdir}/sphinxcontrib/bitbucket.py
101 %{py3_sitescriptdir}/sphinxcontrib/__pycache__/bitbucket.cpython-*.py[co]
102 %{py3_sitescriptdir}/sphinxcontrib_bitbucket-%{version}-py*.egg-info
103 %{py3_sitescriptdir}/sphinxcontrib_bitbucket-%{version}-py*-nspkg.pth
104 %endif
This page took 0.140353 seconds and 3 git commands to generate.