]> git.pld-linux.org Git - packages/python-sphinx_testing.git/blob - python-sphinx_testing.spec
rebuild with python 3.10
[packages/python-sphinx_testing.git] / python-sphinx_testing.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Testing utility classes and functions for Sphinx extensions
8 Summary(pl.UTF-8):      Klasy i funkcje narzędziowe do testowania rozszerzeń Sphinksa
9 Name:           python-sphinx_testing
10 Version:        1.0.1
11 Release:        3
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/sphinx-testing/
15 Source0:        https://files.pythonhosted.org/packages/source/s/sphinx-testing/sphinx-testing-%{version}.tar.gz
16 # Source0-md5:  0f60adab66d877ac8c2c23f78dc7ed32
17 URL:            https://pypi.org/project/sphinx-testing/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.6
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-Sphinx < 2
23 BuildRequires:  python-mock
24 BuildRequires:  python-nose
25 BuildRequires:  python-six
26 %if "%{py_ver}" < "2.7"
27 BuildRequires:  python-unittest2
28 %endif
29 %endif
30 %endif
31 %if %{with python3}
32 BuildRequires:  python3-modules >= 1:3.4
33 BuildRequires:  python3-setuptools
34 %if %{with tests}
35 BuildRequires:  python3-Sphinx
36 BuildRequires:  python3-nose
37 BuildRequires:  python3-six
38 %endif
39 %endif
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  rpmbuild(macros) >= 1.714
42 Requires:       python-modules >= 1:2.6
43 BuildArch:      noarch
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 sphinx-testing provides testing utility classes and functions for
48 Sphinx extensions.
49
50 %description -l pl.UTF-8
51 sphinx-testing udostępnia klasy i funkcje narzędziowe do testowania
52 rozszerzeń Sphinksa.
53
54 %package -n python3-sphinx_testing
55 Summary:        Testing utility classes and functions for Sphinx extensions
56 Summary(pl.UTF-8):      Klasy i funkcje narzędziowe do testowania rozszerzeń Sphinksa
57 Group:          Libraries/Python
58 Requires:       python3-modules >= 1:3.4
59
60 %description -n python3-sphinx_testing
61 sphinx-testing provides testing utility classes and functions for
62 Sphinx extensions.
63
64 %description -n python3-sphinx_testing -l pl.UTF-8
65 sphinx-testing udostępnia klasy i funkcje narzędziowe do testowania
66 rozszerzeń Sphinksa.
67
68 %prep
69 %setup -q -n sphinx-testing-%{version}
70
71 %build
72 %if %{with python2}
73 %py_build
74
75 %if %{with tests}
76 %{__python} -m nose tests
77 %endif
78 %endif
79
80 %if %{with python3}
81 %py3_build
82
83 %if %{with tests}
84 %{__python3} -m nose tests
85 %endif
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %if %{with python2}
92 %py_install
93
94 %py_postclean
95 %endif
96
97 %if %{with python3}
98 %py3_install
99 %endif
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %if %{with python2}
105 %files
106 %defattr(644,root,root,755)
107 %doc AUTHORS CHANGES.rst LICENSE README.rst
108 %{py_sitescriptdir}/sphinx_testing
109 %{py_sitescriptdir}/sphinx_testing-%{version}-py*.egg-info
110 %endif
111
112 %if %{with python3}
113 %files -n python3-sphinx_testing
114 %defattr(644,root,root,755)
115 %doc AUTHORS CHANGES.rst LICENSE README.rst
116 %{py3_sitescriptdir}/sphinx_testing
117 %{py3_sitescriptdir}/sphinx_testing-%{version}-py*.egg-info
118 %endif
This page took 0.119254 seconds and 3 git commands to generate.