]> git.pld-linux.org Git - packages/python-sphinx_rtd_theme.git/blob - python-sphinx_rtd_theme.spec
f3240325529444ee4f66fa871f7d9250fd683f68
[packages/python-sphinx_rtd_theme.git] / python-sphinx_rtd_theme.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  sphinx_rtd_theme
7 Summary:        ReadTheDocs.org theme for Sphinx
8 Summary(pl.UTF-8):      Motyw ReadTheDocs.org dla Sphinksa
9 Name:           python-%{module}
10 Version:        0.4.0
11 Release:        1
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/sphinx_rtd_theme/
15 Source0:        https://files.pythonhosted.org/packages/source/s/sphinx_rtd_theme/%{module}-%{version}.tar.gz
16 # Source0-md5:  2393b28863f9576ca7074d764cb2f0e3
17 URL:            https://github.com/snide/sphinx_rtd_theme/
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 BuildRequires:  python-setuptools
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-modules >= 1:3.3
26 BuildRequires:  python3-setuptools
27 %endif
28 Requires:       python-modules >= 1:2.7
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This is a mobile-friendly Sphinx theme made for readthedocs.org.
34
35 %description -l pl.UTF-8
36 Ten pakiet zawiera przyjazny dla urządzeń przenośnych motyw Sphinksa
37 wykonany przez readthedocs.org.
38
39 %package -n python3-%{module}
40 Summary:        ReadTheDocs.org theme for Sphinx
41 Summary(pl.UTF-8):      Motyw ReadTheDocs.org dla Sphinksa
42 Group:          Libraries/Python
43 Requires:       python3-modules >= 1:3.3
44
45 %description -n python3-%{module}
46 This is a mobile-friendly Sphinx theme made for readthedocs.org.
47
48 %description -n python3-%{module} -l pl.UTF-8
49 Ten pakiet zawiera przyjazny dla urządzeń przenośnych motyw Sphinksa
50 wykonany przez readthedocs.org.
51
52 %prep
53 %setup -q -n %{module}-%{version}
54
55 %build
56 %if %{with python2}
57 %py_build %{?with_tests:test}
58 %endif
59
60 %if %{with python3}
61 %py3_build %{?with_tests:test}
62 %endif
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %if %{with python2}
68 %py_install
69
70 %py_postclean
71 %endif
72
73 %if %{with python3}
74 %py3_install
75 %endif
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %if %{with python2}
81 %files
82 %defattr(644,root,root,755)
83 %doc LICENSE README.rst
84 %{py_sitescriptdir}/%{module}
85 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
86 %endif
87
88 %if %{with python3}
89 %files -n python3-%{module}
90 %defattr(644,root,root,755)
91 %doc LICENSE README.rst
92 %{py3_sitescriptdir}/%{module}
93 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
94 %endif
This page took 0.058384 seconds and 2 git commands to generate.