]> git.pld-linux.org Git - packages/python-sphinx_removed_in.git/blob - python-sphinx_removed_in.spec
rebuild with python 3.10
[packages/python-sphinx_removed_in.git] / python-sphinx_removed_in.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (missing data)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Sphinx Removed In extension
8 Summary(pl.UTF-8):      Rozszerzenie Sphinksa Removed In
9 Name:           python-sphinx_removed_in
10 Version:        0.2.1
11 Release:        4
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/sphinx-removed-in/
15 Source0:        https://files.pythonhosted.org/packages/source/s/sphinx-removed-in/sphinx-removed-in-%{version}.tar.gz
16 # Source0-md5:  c8930e33beb7f3fcaec0166035e2ae02
17 URL:            https://pypi.org/project/sphinx-removed-in/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.5
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-sphinx_testing
23 %endif
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-modules >= 1:3.2
27 BuildRequires:  python3-setuptools
28 %if %{with tests}
29 BuildRequires:  python3-sphinx_testing
30 %endif
31 %endif
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 Requires:       python-modules >= 1:2.5
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 This is a Sphinx extension which recognizes the versionremoved and
40 removed-in directives.
41
42 %description -l pl.UTF-8
43 Rozszerzenie Sphinksa rozpoznające dyrektywy versionremoved i
44 removed-in.
45
46 %package -n python3-sphinx_removed_in
47 Summary:        Sphinx Removed In extension
48 Summary(pl.UTF-8):      Rozszerzenie Sphinksa Removed In
49 Group:          Libraries/Python
50 Requires:       python3-modules >= 1:3.2
51
52 %description -n python3-sphinx_removed_in
53 This is a Sphinx extension which recognizes the versionremoved and
54 removed-in directives.
55
56 %description -n python3-sphinx_removed_in -l pl.UTF-8
57 Rozszerzenie Sphinksa rozpoznające dyrektywy versionremoved i
58 removed-in.
59
60 %prep
61 %setup -q -n sphinx-removed-in-%{version}
62
63 %build
64 %if %{with python2}
65 %py_build
66
67 %if %{with tests}
68 %{__python} tests/test_extension.py
69 %endif
70 %endif
71
72 %if %{with python3}
73 %py3_build
74
75 %if %{with tests}
76 %{__python3} tests/test_extension.py
77 %endif
78 %endif
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %if %{with python2}
84 %py_install
85
86 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/tests
87 %py_postclean
88 %endif
89
90 %if %{with python3}
91 %py3_install
92
93 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/tests
94 %endif
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %if %{with python2}
100 %files
101 %defattr(644,root,root,755)
102 %doc README.rst
103 %{py_sitescriptdir}/sphinx_removed_in
104 %{py_sitescriptdir}/sphinx_removed_in-%{version}-py*.egg-info
105 %endif
106
107 %if %{with python3}
108 %files -n python3-sphinx_removed_in
109 %defattr(644,root,root,755)
110 %doc README.rst
111 %{py3_sitescriptdir}/sphinx_removed_in
112 %{py3_sitescriptdir}/sphinx_removed_in-%{version}-py*.egg-info
113 %endif
This page took 0.1019 seconds and 3 git commands to generate.