]> git.pld-linux.org Git - packages/python-sphinx_copybutton.git/blob - python-sphinx_copybutton.spec
- new
[packages/python-sphinx_copybutton.git] / python-sphinx_copybutton.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Add a copy button to each of your code cells
7 Summary(pl.UTF-8):      Dodanie przycisku do kopiowania do każdej komórki z kodem
8 Name:           python-sphinx_copybutton
9 # keep 0.2.6 here for python2 support
10 Version:        0.2.6
11 Release:        1
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/sphinx-copybutton/
15 Source0:        https://files.pythonhosted.org/packages/source/s/sphinx-copybutton/sphinx-copybutton-%{version}.tar.gz
16 # Source0-md5:  0c3380264ff0b7543bdff0f0f154c87f
17 Patch0:         %{name}-deps.patch
18 URL:            https://pypi.org/project/sphinx-copybutton/
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.5
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules >= 1:3.2
25 BuildRequires:  python3-setuptools
26 %endif
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.714
29 Requires:       python-modules >= 1:2.5
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 A small Sphinx extension to add a "copy" button to code blocks.
35
36 %description -l pl.UTF-8
37 Małe rozszerzenie Sphinksa dodające przycisk kopiujący do fragmentów
38 kodu.
39
40 %package -n python3-sphinx_copybutton
41 Summary:        Add a copy button to each of your code cells
42 Summary(pl.UTF-8):      Dodanie przycisku do kopiowania do każdej komórki z kodem
43 Group:          Libraries/Python
44 Requires:       python3-modules >= 1:3.2
45
46 %description -n python3-sphinx_copybutton
47 A small Sphinx extension to add a "copy" button to code blocks.
48
49 %description -n python3-sphinx_copybutton -l pl.UTF-8
50 Małe rozszerzenie Sphinksa dodające przycisk kopiujący do fragmentów
51 kodu.
52
53 %prep
54 %setup -q -n sphinx-copybutton-%{version}
55 %patch0 -p1
56
57 %build
58 %if %{with python2}
59 %py_build
60 %endif
61
62 %if %{with python3}
63 %py3_build
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %if %{with python2}
70 %py_install
71
72 %py_postclean
73 %endif
74
75 %if %{with python3}
76 %py3_install
77 %endif
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %if %{with python2}
83 %files
84 %defattr(644,root,root,755)
85 %doc README.md
86 %{py_sitescriptdir}/sphinx_copybutton
87 %{py_sitescriptdir}/sphinx_copybutton-%{version}-py*.egg-info
88 %endif
89
90 %if %{with python3}
91 %files -n python3-sphinx_copybutton
92 %defattr(644,root,root,755)
93 %doc README.md
94 %{py3_sitescriptdir}/sphinx_copybutton
95 %{py3_sitescriptdir}/sphinx_copybutton-%{version}-py*.egg-info
96 %endif
This page took 0.100449 seconds and 3 git commands to generate.