]> git.pld-linux.org Git - packages/python-sphinx-prompt.git/blob - python-sphinx-prompt.spec
50c54417f385d0564dde2b8e5e162fc7a765b785
[packages/python-sphinx-prompt.git] / python-sphinx-prompt.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Sphinx directive to add unselectable prompt
7 Summary(pl.UTF-8):      Dyrektywa Sphinksa do dodawania pytań bez możliwości wyboru
8 Name:           python-sphinx-prompt
9 # keep 1.4.x here for python2 support
10 Version:        1.4.0
11 Release:        1
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/sphinx-prompt/
15 Source0:        https://files.pythonhosted.org/packages/source/s/sphinx-prompt/sphinx-prompt-%{version}.tar.gz
16 # Source0-md5:  4b217991abf068ce9e22cf10393faf56
17 URL:            http://github.com/sbrunner/sphinx-prompt
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 2
22 BuildRequires:  python-setuptools
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-modules >= 1:3.2
26 BuildRequires:  python3-setuptools
27 %endif
28 Requires:       python-modules >= 2
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Sphinx directive to add unselectable prompt.
34
35 %description -l pl.UTF-8
36 Dyrektywa Sphinksa do dodawania pytań bez możliwości wyboru.
37
38 %package -n python3-sphinx-prompt
39 Summary:        Sphinx directive to add unselectable prompt
40 Summary(pl.UTF-8):      Dyrektywa Sphinksa do dodawania pytań bez możliwości wyboru
41 Group:          Libraries/Python
42 Requires:       python3-modules >= 1:3.2
43
44 %description -n python3-sphinx-prompt
45 Sphinx directive to add unselectable prompt.
46
47 %description -n python3-sphinx-prompt -l pl.UTF-8
48 Dyrektywa Sphinksa do dodawania pytań bez możliwości wyboru.
49
50 %prep
51 %setup -q -n sphinx-prompt-%{version}
52
53 %build
54 %if %{with python2}
55 %py_build
56 %endif
57
58 %if %{with python3}
59 %py3_build
60 %endif
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %if %{with python2}
66 %py_install
67
68 %py_postclean
69 %endif
70
71 %if %{with python3}
72 %py3_install
73 %endif
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %if %{with python2}
79 %files
80 %defattr(644,root,root,755)
81 %doc LICENSE README.rst
82 %{py_sitescriptdir}/sphinx-prompt
83 %{py_sitescriptdir}/sphinx_prompt-%{version}-py*.egg-info
84 %endif
85
86 %if %{with python3}
87 %files -n python3-sphinx-prompt
88 %defattr(644,root,root,755)
89 %doc LICENSE README.rst
90 %{py3_sitescriptdir}/sphinx-prompt
91 %{py3_sitescriptdir}/sphinx_prompt-%{version}-py*.egg-info
92 %endif
This page took 0.045833 seconds and 2 git commands to generate.