]> git.pld-linux.org Git - packages/python-sortedcontainers.git/blob - python-sortedcontainers.spec
caed883f77faa43fd43c9b9a5850c5a74816fce9
[packages/python-sortedcontainers.git] / python-sortedcontainers.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # tests (tox based)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Sorted Containers - Sorted List, Sorted Dict, Sorted Set
8 Summary(pl.UTF-8):      Posortowane kontenery - lista, słownik, zbiór
9 Name:           python-sortedcontainers
10 Version:        2.4.0
11 Release:        1
12 License:        Apache v2.0
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/sortedcontainers/
15 Source0:        https://files.pythonhosted.org/packages/source/s/sortedcontainers/sortedcontainers-%{version}.tar.gz
16 # Source0-md5:  50eeb6cb739568b590b28f9a3f445c78
17 URL:            https://pypi.org/project/sortedcontainers/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-tox
23 %endif
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-modules >= 1:3.2
27 BuildRequires:  python3-setuptools
28 %if %{with tests}
29 BuildRequires:  python3-tox
30 %endif
31 %endif
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 Requires:       python-modules >= 1:2.7
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Sorted Containers is an Apache2 licensed sorted collections library,
40 written in pure-Python, and fast as C-extensions.
41
42 %description -l pl.UTF-8
43 Sorted Containers to wydana na licencji Apache2 biblioteka sortowanych
44 kolekcji, napisana w czystym Pythonie, szybka jak rozszerzenia w C.
45
46 %package -n python3-sortedcontainers
47 Summary:        Sorted Containers - Sorted List, Sorted Dict, Sorted Set
48 Summary(pl.UTF-8):      Posortowane kontenery - lista, słownik, zbiór
49 Group:          Libraries/Python
50 Requires:       python3-modules >= 1:3.2
51
52 %description -n python3-sortedcontainers
53 Sorted Containers is an Apache2 licensed sorted collections library,
54 written in pure-Python, and fast as C-extensions.
55
56 %description -n python3-sortedcontainers -l pl.UTF-8
57 Sorted Containers to wydana na licencji Apache2 biblioteka sortowanych
58 kolekcji, napisana w czystym Pythonie, szybka jak rozszerzenia w C.
59
60 %prep
61 %setup -q -n sortedcontainers-%{version}
62
63 %build
64 %if %{with python2}
65 %py_build %{?with_tests:test}
66 %endif
67
68 %if %{with python3}
69 %py3_build %{?with_tests:test}
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %if %{with python2}
76 %py_install
77
78 %py_postclean
79 %endif
80
81 %if %{with python3}
82 %py3_install
83 %endif
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %if %{with python2}
89 %files
90 %defattr(644,root,root,755)
91 %doc LICENSE README.rst
92 %{py_sitescriptdir}/sortedcontainers
93 %{py_sitescriptdir}/sortedcontainers-%{version}-py*.egg-info
94 %endif
95
96 %if %{with python3}
97 %files -n python3-sortedcontainers
98 %defattr(644,root,root,755)
99 %doc LICENSE README.rst
100 %{py3_sitescriptdir}/sortedcontainers
101 %{py3_sitescriptdir}/sortedcontainers-%{version}-py*.egg-info
102 %endif
This page took 0.072653 seconds and 2 git commands to generate.