]> git.pld-linux.org Git - packages/python-social-auth-app-django.git/blob - python-social-auth-app-django.spec
11bdd8d499fc86c68dd9d3b980c404c244d322f7
[packages/python-social-auth-app-django.git] / python-social-auth-app-django.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_with     python3 # CPython 3.x module
6
7 %define         module          social_django
8 %define         pypi_name       social-auth-app-django
9 %define         egg_name        social_auth_app_django
10 Summary:        Python Social Auth - Application - Django
11 Name:           python-%{pypi_name}
12 Version:        1.2.0
13 Release:        1
14 License:        BSD
15 Group:          Libraries/Python
16 Source0:        https://files.pythonhosted.org/packages/source/s/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
17 # Source0-md5:  ec78f03b8053ecaa4d33b35a128c00bd
18 URL:            https://github.com/python-social-auth/social-app-django
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 %if %{with python2}
22 BuildRequires:  python-modules
23 BuildRequires:  python-setuptools
24 BuildRequires:  python-social-auth-core >= 1.2.0
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-modules
28 BuildRequires:  python3-setuptools
29 BuildRequires:  python3-social-auth-core >= 1.2.0
30 %endif
31 Requires:       python-modules
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Python Social Auth is an easy to setup social
37 authentication/registration mechanism with support for several
38 frameworks and auth providers.
39
40 This is the Django component of the python-social-auth ecosystem, it
41 implements the needed functionality to integrate social-auth-core in a
42 Django based project.
43
44 %package -n python3-%{pypi_name}
45 Summary:        Python Social Auth - Application - Django
46 Group:          Libraries/Python
47
48 %description -n python3-%{pypi_name}
49 Python Social Auth is an easy to setup social
50 authentication/registration mechanism with support for several
51 frameworks and auth providers.
52
53 This is the Django component of the python-social-auth ecosystem, it
54 implements the needed functionality to integrate social-auth-core in a
55 Django based project.
56
57 %prep
58 %setup -q -n %{pypi_name}-%{version}
59
60 %build
61 %if %{with python2}
62 %py_build %{?with_tests:test}
63 %endif
64
65 %if %{with python3}
66 %py3_build %{?with_tests:test}
67 %endif
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 %if %{with python2}
72 %py_install
73 %py_postclean
74 %endif
75
76 %if %{with python3}
77 %py3_install
78 %endif
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %if %{with python2}
84 %files
85 %defattr(644,root,root,755)
86 %doc README.md LICENSE
87 %{py_sitescriptdir}/%{module}
88 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
89 %endif
90
91 %if %{with python3}
92 %files -n python3-%{pypi_name}
93 %defattr(644,root,root,755)
94 %doc README.md LICENSE
95 %{py3_sitescriptdir}/%{module}
96 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
97 %endif
This page took 0.084099 seconds and 2 git commands to generate.