]> git.pld-linux.org Git - packages/python-soaplib.git/blob - python-soaplib.spec
56ee4644b89e57bbed7d08f4c7feead45ee5291a
[packages/python-soaplib.git] / python-soaplib.spec
1 # TODO
2 # - better group
3
4 %define         _rc     beta2
5 %define         module  soaplib
6 Summary:        A transport and architecture agnostic soap (de)serialization library that focuses on making small, rpc-like messaging work.
7 Name:           python-%{module}
8 Version:        2.0.0
9 Release:        0.1_%{_rc}
10 License:        LGPL
11 Group:          Development/Languages/Python
12 Source0:        http://pypi.python.org/packages/source/s/%{module}/%{module}-%{version}-%{_rc}.tar.gz
13 # Source0-md5:  294bc8db05011bfa14e00a6a9368e2ae
14 URL:            http://pypi.python.org/pypi/%{module}/%{version}-%{_rc}
15 BuildRequires:  python-distribute
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.228
18 Requires(post,preun):   /sbin/chkconfig
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-%{_rc}-root-%(id -u -n)
21
22 %description
23 This is a simple, easily extendible soap library that provides several useful
24 tools for creating and publishing soap web services in python.  This package
25 features on-demand wsdl generation for the published services, a
26 wsgi-compliant web application, support for complex class structures, binary
27 attachments, and a simple framework for creating additional serialization 
28 mechanisms.
29     
30 This project uses lxml as it's XML API, providing full namespace support.
31         
32 %prep
33 %setup -q -n %{module}-%{version}-%{_rc}
34
35 %build
36 %{__python} setup.py build
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %{__python} setup.py install \
41         --skip-build \
42         --optimize=2 \
43         --root=$RPM_BUILD_ROOT
44
45 %py_postclean
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc PKG-INFO
53
54 %{py_sitescriptdir}/%{module}
55 %if "%{py_ver}" > "2.4"
56 %{py_sitescriptdir}/%{module}-*.egg-info
57 %endif
58 %attr(644,root,root) %{py_sitescriptdir}/%{module}-*pth
This page took 0.060372 seconds and 2 git commands to generate.