]> git.pld-linux.org Git - packages/python-snowballstemmer.git/blob - python-snowballstemmer.spec
rebuild with python 3.10
[packages/python-snowballstemmer.git] / python-snowballstemmer.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  snowballstemmer
7 Summary:        Stemmer algorithms generated from Snowball algorithms
8 Summary(pl.UTF-8):      Algorytmy wyznaczające rdzeniesłów wygenerowane z algorytmów Snowball
9 Name:           python-%{module}
10 Version:        2.2.0
11 Release:        3
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/snowballstemmer
15 Source0:        https://files.pythonhosted.org/packages/source/s/snowballstemmer/%{module}-%{version}.tar.gz
16 # Source0-md5:  4332ddc7bbee0f344a03915b2ad59a54
17 URL:            https://github.com/snowballstem/snowball
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.6
22 BuildRequires:  python-setuptools
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-modules >= 1:3.4
26 BuildRequires:  python3-setuptools
27 %endif
28 Requires:       python-modules >= 1:2.6
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This package provides 26 stemmer algorithms (25 languages + Porter
34 English stemmer) generated from Snowball algorithms.
35
36 It includes following language algorithms:
37  - Arabic
38  - Basque
39  - Catalan
40  - Danish
41  - Dutch
42  - English (Standard, Porter)
43  - Finnish
44  - French
45  - German
46  - Greek
47  - Hindi
48  - Hungarian
49  - Indonesian
50  - Irish
51  - Italian
52  - Lithuanian
53  - Nepali
54  - Norwegian
55  - Portuguese
56  - Romanian
57  - Russian
58  - Spanish
59  - Swedish
60  - Tamil
61  - Turkish
62
63 This is a pure Python stemming library. If PyStemmer is available,
64 this module uses it to accelerate.
65
66 %description -l pl.UTF-8
67 Ten pakiet udostępnia 26 algorytmów znajdujących rdzenie słów (25
68 języków + angielski Portera), wygenerowane z algorytmów Snowball.
69
70 Zawiera algorytmy dla następujących języków:
71  - arabski
72  - baskijski
73  - kataloński
74  - duński
75  - holenderski
76  - angielski (standardowy i Portera)
77  - fiński
78  - francuski
79  - niemiecki
80  - grecki
81  - hindi
82  - węgierski
83  - indonezyjski
84  - irlandzki
85  - włoski
86  - litewski
87  - nepalski
88  - norweski
89  - portugalski
90  - rumuński
91  - rosyjski
92  - hiszpański
93  - szwedzki
94  - tamilski
95  - turecki
96
97 Ta biblioteka jest napisana w czystym Pythonie. Jeśli dostępny jest
98 PyStemmer, jest używany w celu przyspieszenia.
99
100 %package -n python3-%{module}
101 Summary:        Stemmer algorithms generated from Snowball algorithms
102 Summary(pl.UTF-8):      Algorytmy wyznaczające rdzeniesłów wygenerowane z algorytmów Snowball
103 Group:          Libraries/Python
104 Requires:       python3-modules >= 1:3.4
105
106 %description -n python3-%{module}
107 This package provides 26 stemmer algorithms (25 languages + Porter
108 English stemmer) generated from Snowball algorithms.
109
110 It includes following language algorithms:
111  - Arabic
112  - Basque
113  - Catalan
114  - Danish
115  - Dutch
116  - English (Standard, Porter)
117  - Finnish
118  - French
119  - German
120  - Greek
121  - Hindi
122  - Hungarian
123  - Indonesian
124  - Irish
125  - Italian
126  - Lithuanian
127  - Nepali
128  - Norwegian
129  - Portuguese
130  - Romanian
131  - Russian
132  - Spanish
133  - Swedish
134  - Tamil
135  - Turkish
136
137 This is a pure Python stemming library. If PyStemmer is available,
138 this module uses it to accelerate.
139
140 %description -n python3-%{module} -l pl.UTF-8
141 Ten pakiet udostępnia 26 algorytmów znajdujących rdzenie słów (25
142 języków + angielski Portera), wygenerowane z algorytmów Snowball.
143
144 Zawiera algorytmy dla następujących języków:
145  - arabski
146  - baskijski
147  - kataloński
148  - duński
149  - holenderski
150  - angielski (standardowy i Portera)
151  - fiński
152  - francuski
153  - niemiecki
154  - grecki
155  - hindi
156  - węgierski
157  - indonezyjski
158  - irlandzki
159  - włoski
160  - litewski
161  - nepalski
162  - norweski
163  - portugalski
164  - rumuński
165  - rosyjski
166  - hiszpański
167  - szwedzki
168  - tamilski
169  - turecki
170
171 Ta biblioteka jest napisana w czystym Pythonie. Jeśli dostępny jest
172 PyStemmer, jest używany w celu przyspieszenia.
173
174 %prep
175 %setup -q -n %{module}-%{version}
176
177 %build
178 %if %{with python2}
179 %py_build
180 %endif
181
182 %if %{with python3}
183 %py3_build
184 %endif
185
186 %install
187 rm -rf $RPM_BUILD_ROOT
188
189 %if %{with python2}
190 %py_install
191
192 %py_postclean
193 %endif
194
195 %if %{with python3}
196 %py3_install
197 %endif
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %if %{with python2}
203 %files
204 %defattr(644,root,root,755)
205 %doc COPYING NEWS README.rst
206 %{py_sitescriptdir}/%{module}
207 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
208 %endif
209
210 %if %{with python3}
211 %files -n python3-%{module}
212 %defattr(644,root,root,755)
213 %doc COPYING NEWS README.rst
214 %{py3_sitescriptdir}/%{module}
215 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
216 %endif
This page took 0.062695 seconds and 3 git commands to generate.