]> git.pld-linux.org Git - packages/python-snowballstemmer.git/blob - python-snowballstemmer.spec
- updated to 1.2.1
[packages/python-snowballstemmer.git] / python-snowballstemmer.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  snowballstemmer
7 Summary:        Stemmer algorithms generated from Snowball algorithms
8 Summary(pl.UTF-8):      Algorytmy wyznaczające rdzeniesłów wygenerowane z algorytmów Snowball
9 Name:           python-%{module}
10 Version:        1.2.1
11 Release:        1
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/pypi/snowballstemmer
15 Source0:        https://pypi.python.org/packages/source/s/snowballstemmer/%{module}-%{version}.tar.gz
16 # Source0-md5:  643b019667a708a922172e33a99bf2fa
17 URL:            https://github.com/shibukawa/snowball_py
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-setuptools
25 %endif
26 Requires:       python-modules
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This package provides 16 stemmer algorithms (15 + Porter English
32 stemmer) generated from Snowball algorithms.
33
34 It includes following language algorithms:
35  - Danish
36  - Dutch
37  - English (Standard, Porter)
38  - Finnish
39  - French
40  - German
41  - Hungarian
42  - Italian
43  - Norwegian
44  - Portuguese
45  - Romanian
46  - Russian
47  - Spanish
48  - Swedish
49  - Turkish
50
51 This is a pure Python stemming library. If PyStemmer is available,
52 this module uses it to accelerate.
53
54 %description -l pl.UTF-8
55 Ten pakiet udostępnia 16 algorytmów znajdujących rdzenie słów (15 +
56 angielski Portera), wygenerowane z algorytmów Snowball.
57
58 Zawiera algorytmy dla następujących języków:
59  - duński
60  - holenderski
61  - angielski (standardowy i Portera)
62  - fiński
63  - francuski
64  - niemiecki
65  - węgierski
66  - włoski
67  - norweski
68  - portugalski
69  - rumuński
70  - rosyjski
71  - hiszpański
72  - szwedzki
73  - turecki
74
75 Ta biblioteka jest napisana w czystym Pythonie. Jeśli dostępny jest
76 PyStemmer, jest używany w celu przyspieszenia.
77
78 %package -n python3-%{module}
79 Summary:        Stemmer algorithms generated from Snowball algorithms
80 Summary(pl.UTF-8):      Algorytmy wyznaczające rdzeniesłów wygenerowane z algorytmów Snowball
81 Group:          Libraries/Python
82 Requires:       python3-modules
83
84 %description -n python3-%{module}
85 This package provides 16 stemmer algorithms (15 + Porter English
86 stemmer) generated from Snowball algorithms.
87
88 It includes following language algorithms:
89
90  - Danish
91  - Dutch
92  - English (Standard, Porter)
93  - Finnish
94  - French
95  - German
96  - Hungarian
97  - Italian
98  - Norwegian
99  - Portuguese
100  - Romanian
101  - Russian
102  - Spanish
103  - Swedish
104  - Turkish
105
106 This is a pure Python stemming library. If PyStemmer is available,
107 this module uses it to accelerate.
108
109 %description -n python3-%{module} -l pl.UTF-8
110 Ten pakiet udostępnia 16 algorytmów znajdujących rdzenie słów (15 +
111 angielski Portera), wygenerowane z algorytmów Snowball.
112
113 Zawiera algorytmy dla następujących języków:
114  - duński
115  - holenderski
116  - angielski (standardowy i Portera)
117  - fiński
118  - francuski
119  - niemiecki
120  - węgierski
121  - włoski
122  - norweski
123  - portugalski
124  - rumuński
125  - rosyjski
126  - hiszpański
127  - szwedzki
128  - turecki
129
130 Ta biblioteka jest napisana w czystym Pythonie. Jeśli dostępny jest
131 PyStemmer, jest używany w celu przyspieszenia.
132
133 %prep
134 %setup -q -n %{module}-%{version}
135
136 %build
137 %if %{with python2}
138 %py_build
139 %endif
140
141 %if %{with python3}
142 %py3_build
143 %endif
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 %if %{with python2}
149 %py_install
150
151 %py_postclean
152 %endif
153
154 %if %{with python3}
155 %py3_install
156 %endif
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %if %{with python2}
162 %files
163 %defattr(644,root,root,755)
164 %doc README.rst
165 %{py_sitescriptdir}/%{module}
166 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
167 %endif
168
169 %if %{with python3}
170 %files -n python3-%{module}
171 %defattr(644,root,root,755)
172 %doc README.rst
173 %{py3_sitescriptdir}/%{module}
174 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
175 %endif
This page took 0.110677 seconds and 3 git commands to generate.